Cannot create unknown type '{}GetRobotAsset'

Good day. May I know if anyone had an issue like this? May I know the solution
Cannot create unknown type ‘{}GetRobotAsset’.

1 Like


Below thread might help you.

Cannot create unknown type - V2018.2.3 Onwards - Troubleshooting steps

Just to add details, here are the things we tried to troubleshoot the issue:

  1. Opened studio and updated the activities/packages – didn’t work
  2. Copied all the activities and packages in the QA machine which is working during testing but still encountering the same error when bot is initiated
  3. Deleted everything in the package folder so it can be re-download when bot is run but same issue (based on Cannot create unknown type - V2018.2.3 Onwards - Troubleshooting steps)

However, if I open studio and run the bot (queue and processor bot) directly from studio, it is working fine as expected. Which leads me to believe that problem lies with orchestrator. So…

  1. I disconnected the bot and reconnected it once again in orchestrator – not successful
  2. Re-published the package but same issue.

We are only getting this problem when run is initiated via robot or orchestrator. Any fix on this issue?

Hi All,

I am also facing same issue. Any one know the solution for this
Cannot create unknown type ‘{}GetRobotAsset’.