Cannot connect to a robot

connection

#1

Hi,

I’m trying to connect to a robot from the Orchestrator, but I keep getting this message…

“An existing connection was forcibly closed by the remote host”

I have copy/pasted the Robot Key and used “https://platform.uipath.com” as the URL.
I have also checked the credentials (domain/password) used for the robot.

Does anyone have any ideas please?

Regards
Jono


#2

Hello!

Here’s some FAQ about Orchestrator. Maybe you found your answer :slight_smile:

Regards,


#3

Thanks Lucas,

I’ve looked at the message in the troubleshooting guide. There are three bullet points shown for the error I’m getting, but I don’t know what to do in order to try and fix this issue.

I have deleted all the robots, environments, job etc and started again from scratch. Still no joy.

I have just tried again using another tenancy, but again I cannot get the robot to connect.

Are there any other resources available please that could help?

Regards
Jono


#4

I think that are a network issue (firewall, proxy and stuff). What’s is the status of the Robot after you setup it?

Regards,


#5

Hi,

From the webpage, the robot is always “Disconnected”.

If I try and use the Robot from the taskbar, then that’s when I get the message.

Regards
Jono


#6

Okay.

Try to follow this guide step-by-step and see if works.

If doesn’t then you need to contact your network group to check if are something blocking the connection between Robot and Orchestrator.

Regards,


#7

Hi Lucas,

I contacted our support team and I can now connect to a robot on my machine. So many thanks for pointing me in the right direction.

I do however, have another issue (sorry). As soon as I try and run a job, I get “The remote server returned an error: (403) Forbidden.” This happens almost immediately the job starts.

Any clues sir?


#8

Are you working behind a Firewall? I think that is something blocking the connection between the Robot and the Orchestrator.


#9

Thanks for the pointer.

I made some adjustments to the Firewall settings on my machine, and now the robots are working with the Orchestrator.

Many thanks.
~ Jono


#10

Hi,

I am also facing the same issue. Whenever i am trying to configure it, this is what i get-


#11

open the Run prompt and type “Services.msc” in services and check the status of UiPath Robot it should be running… and try once by restarting the same