Cannot communicate with browser - both Chrome & Edge


I encounter one issue for several RPAs lately: Cannot communicate with browser - please check UiPath extension. This happens for both Chrome and Edge. I use UiPath Studio Enterprise.

What have I done trying to solve, but without success:

  • reinstall Chrome & Edge
  • reinstall extension & enable it ( I have tried installing for Current User, Group Policy Online - none of it works)
  • reinstall Studio
  • downgrade to several UiPath.UiAutomation packages

Can you please support solving this issue?


Hi @e.vasile ,

Check this below link,

Hope this may help you :slight_smile:

@e.vasile Try to upgrade UI Automation package to maximum.

Hi @Manish540 ,

Already tried this, it works first time, but after some runs the error reappears.



I have tried all package versions, but unfortunately error still occurs.


Hi @e.vasile

As far as I remember we had similar error happening when some members of our team were using their own profile in Chrome.
Robot would then open Chrome in guest profile and it’s impossible to run automation of windows when more then 1 profile is opened.

However I don’t remember how we ended up solving this in the end.

Please check chrome extension plug in

Enable developer mode