Cannot access shared mailbox


We have a few bots that pull email from shared mailboxes that stopped working over the weekend. Whenever they run now, this error is received:

Exchange Web Services are not currently available for this request because none of the Client Access Servers in the destination site could process the request.

I tested the bot and changed it to pull from it’s own mailbox and it works without an issue, it’s only when they attempt to read shared mailboxes. Has anyone encountered this error before? Our company uses Office365 for mail, but we do have a hybrid setup. We are using the Get Exchange Mail Message activity, I also setup a Microsoft O365 Scope and a Get Mail activity, but we receive the same error.

I was able to resolve this issue. We had to update the UIPath.Mail.Activities package to version 1.9.5, this gave us the option to to enter Office 365 Settings for the Get Exchange Mail Messages activity. I then had to work with my Azure team to create an Azure Enterprise Application that has the following permissions:

Once the application was created we had to put the application ID and Azure Tenant ID into the activity and (once replication had finished to Exchange Online) it worked as normal again.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.