Can’t find selector for Attach browser activity

I am since day’s work on an topic but I can’t solve it.
Hope that someone has any Idea how to fix my problem.

Before I go in detail let me share where the problem is.

I have to access in my process a view web sites.
I am using attach Browser activity and do a view clicks to get the Webpage ready for future use.
Attach Browser activity and related Tab from IE is use later on in the process executions.

I have installed Studio 18.4.5
I have user Orechestrator 18.4.5
Uipath.System.Activites 19.7.0
Uipath.UiAutomation.Activities 19.7.0
All dependencies are checked and installed on Orchestrator
Robot Process is deployed without error all activity packages are installed on Robot workstation.

Now my problem.
I can indicate In Studio Workstation in UI Explorer the IE Tab I am working on.

Process is running well in Studio I published the Process and moved to our PRE PROD robot workstation Process worked fine and Selector found and clicks are done as needed.

Now I transport Robot Process to PROD Robot Workstations and now I get selector error for the Attach Browser activity.
As I did not understand why, I open Studio on PROD Robot Workstation to see why selector was not found.

If I try to indicate the selector on PROD Robot workstation but on this workstation seems to be that selector can’t be found. If I use UI Explorer to indicate the Tab, IE Session stopped and start and afterward again. In studio I got as result in my Attache Browser activity only “” without title of my web page.
So for me I can’t find the selector on that Web page.

Might it be that I need Plug in for IE 11?
I had already checked security setting in Internet options on my PROD Robot Workstation settings but I can’t find something to get my problem solved.
I was thinking about to change my workflow but I try to prevent this as I have plenty of other sequences and imbedded workflows with same logic.

Hope that someone from community has an idea where my problem is coming from and how I can get it solved.
Thanks in advance for your help.

Have you tried to open the browser and in the output get the UiBrowser object? And subsequently use this object in the AttachBrowser activities.

main problem I have:
On Studio workstation selector is identified and on Robot workstation not.

  1. Open IE11
  2. Open Studio
  3. Use Attach Browser in sequence
  4. with Inicate on screen to get Browser TAB
    I got selectoer es exampel with MSN
all Do activites for the IE Tab can be done without any problem

Same on Robot workstation

  1. Open IE11
  2. Open Studio
  3. Use Attch Browser in sequence
  4. with Inicate on screen I got afte 2 min only
So I can't indicate the selectore in the studio. Same happend from if I execute the process as unattende Robot process. Somthing is missing on my Robot workstation to work with the selector.

It is as well visible if yo open the UI Explorer
on Studio selectore for the IE Tab and other applicaiton selectore are visible and can be inidcated
On Robot workstation is is not the case.
It look’s that it is not only relevant from IE11 I miss as well selecoter for Studio or other windows applications.

Something is blocking my selector and I have not an ide where it and how I can unblock it.