C# project will not open

Where do I get those?


did you resolved this issue ?

I changed the community edition to 2019.9.2. It works.

How did you change versions or dit you re install

I just delete the lastest version folder and the project will be opened with the previous version.


1 Like

Please see this post here:

1 Like

so c# will not be supported in the future version?

I believe the plan is to re-introduce it after the stable enterprise 2019.10 release.


this is a bit ridiculous. I understand beta, preview, whatever you call it. But to disable the whole function just “because” is ridiculous.

Now, I created an evaluation project, played with it, it became quite big and worked quite fine. Not much code in there, very simple one, all compiled and worked well.

I closed the project (restarting computers just sucks, hey) and tried to get back in. No luck.
I recreated another project which has csharp as a language, worked, closed it, reopened it…all good. Original project, fails to open.

Now, I would say the “feature” is still there but not working.

Is there a timeline to when new version is released or should we start evaluating other products?

1 Like

I have to agree with the person above me, I think it’s very unprofessional to introduce a feature, albeit in a beta, but then remove it without any sort of heads-up or reverse-compatibility.

Sitting now with a large project which is time sensitive, which I need to convert to VB to get it to work.

Also not being able to give some sort of date for re-introduction, it’s just bad service.


I confirm this bug.
2019.10.0-beta.252 I can not open project created previously with C# language, Studio give a message C# is not supported.
Changing Preview to Stable not helping…
That is very frustrating…

1 Like

Hi there @Andrey_Kovalev

C# is supported in ‘Invoke Code’ (if at all you have had to use large chunks of code then it would be invoke code as all the other activities have one liners which are easy to replicate in VB)

Also importing the assembly Microsoft.Csharp will fix most issues (if it doesnt hen manually add the assembly reference by opening the xaml in notepad)

PS : I use Csharp code all the time with version 2018.4.5

1 Like

Hello Everyone,
I have just little update about lack of C# in current release. Please check this post:

Why not simply enable this feature in an experimental 11.xx beta version ???
I cannot open all my projects I made using C# (I found C# support quite good in fact) ! It’s very frustrating ! I have a certification to do and I wanted to summarize using all my samples (Only lesson 11 and 12 are with VB). It’s as if I lost weeks of work !

Please help us !

1 Like

Hi @Kuro_Tenshi

Why not simply enable this feature in an experimental 11.xx beta version ???

I think it will be indeed enabled with the next Preview version.

Thank you. I look forward to it !

Still no C# with UIPath Studio 19.11.0 Beta 2…

Still no updates on this. What’s going on?

1 Like

Where the C# support, give it back for us

1 Like

I need C# support for my projects. I don’t want to use old VB, I know and like C#.

You declared in November that next version will have C# support but when is that going to be? Or was it just a blunder?