Bulk AddQueueItemsparameters must not be null

Hi Folks,

I wanted to add 10k records to orchestrator queue from excel.

I used read range and stored the data in datatable and tried adding it to the queue using add bulk queue item and getting the attached error.

I tried both commit type but no luck.

Please help.


Can you check if your dt is empty by any chance

You can remove orch folder path as it is already connected to the same folder(optional)


1 Like

you mean my inputfile?

i am getting the below error

I have 10k records in the excel

Hi @sharu_priya,

Try to give your your Queue name with “” like below


1 Like


Your input should contain only those columns which are to be added to queue…if you already have a schema defined then it ahpuld match…and if unique reference is enabled…then Reference is a mandatory column


1 Like

Thanks… but it does not work

Hey Thanks much… Can you please explain in detail?


Say your items needed in queue are name and age and if unique reference is set in queue then your columns would be name ,age and Reference…please check below for more details on different options available

And also…while reading data did you check the add headers column?

And as well the column names should contain only letters,number and underscores …no special characters are allowed…


Hi Anil,

I tried same as the video… and checked unique reference too


Can you show the columns in your csv please

Does it include Reference column? And what other columns are there? …those columns shpuld not have special characters


1 Like

Hello @sharu_priya

Please check dtOutpur.Rows.Count to check the number of rows in the datatable. Also, Have you already added any data to the queue or have you configured any input schema while creating queue?

If not you can directly use your datatable in the Bulkadd queue item. But the datatable should have some rows.


1 Like

Hi Rahul…
I have solved … in my column name there was a full stop…i removed that and i tried… it works

There was a full stop…i removed and tried . Thank you

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.