Bulk Add Queue Items: Operation returned an invalid status code 'BadRequest'


I am trying to add excel sheets as datables to an Orchestraror queue using the Workbook, Read Range activity but am getting Bulk Add Queue Items: Operation returned an invalid status code ‘BadRequest’ error when I am running the workflow.

Kindly help me in understanding what am i doing wrong and also if possible suggest a solution.

Thanks in advance.

Kindly update the Queue Name accordingly.

I am attaching the xaml files and excel files.
Queues.zip (65.2 KB)

1 Like

It looks like you’re getting itesm from “test_queue”, but sending them to “default”. Check that the queue you’re uploading the items to exists.

1 Like

the queue names are not the issue i have checked that. i made a mistake in uploading the right workflow.

can you kindly create a queue on your Orchestrator and check if the Bulk Add items to queue is working. This will help me a lot.

I’ve experimented with this, and I haven’t seen this before. Apparently Bulk Queue Items doesn’t like your header “S.No” because it has a period in it. You can either remove the periods or pull the data without headers, delete the first row, and rename the headers.


Thanks for the answer. It helped me. I also used S.No as Column name.

Thanks a lot! that was a saver!
Apparently also # is an issue

1 Like

Thanks for the answer. It helped me too. even i used the S.no which leads to same error.

appreciate your comment

Interesting that I was just faced with this error exactly because my source data has a S.No column.

I also had other columns with . in the column name. I had to remove all the periods before Bulk Add Queue Items would work.

Hey UiPath, can you fix this?

1 Like

This solved me as well. Thanks a lot

Hi, for this error just uncheck the property AddHeaders in (Read Range activity).


Thanks a lot for this insight, I would have taken a long time to figure out this bug otherwise! :smiley:

Read the thread, the issue is having a column name with a . in it. Other characters like # can also cause it.

I get the same error, change the name of the header of my column and the continuous error.

How could I fix it?

What are the column names in your datatable?