Bug -> Packing of Windows version projects -> AzureDevops


We have tested two different repos with the same pipeline for CI and CD.
The project with type Windows Legacy packs the artifacts and deploys as intended.

The project with type Windows version does not find the “C:\agent_work_tool\uipcli\21.10.8280-12384\WindowsPlatformManifest.txt” during the pack stage of CI

The error message (Line 17 is the source of the error) :

The error message is in a way correct as the file WindowsPlatformManifest.txt does not exist in that folder. But ideally the UiPath Pack Stage should look for WindowsPlatformManifest.txt file in the x64 folder.

We think this is a bug in the UiPath Pack stage in AzureDevops which does not direct the pack to look for the correct files in the correct location.

UiPath Pack looks here

But not in the x64 folder

Our AzurePipeline agent version is 2.210.0

Thank you for your consideration!

@ThomasStocker tagging you here as you can direct it to the right people.

Hi @jeevith

Could you let us know if you have maybe taken this up with our technical support and your eventual findings?

EDIT. Our team took note of the issue and will look into it.

Hi @loginerror,

We have been trying to resolve this with the technical support but sadly still waiting for a resolution.

The way the support emails work is not effective at all. The case handler is not notified when we send an email (same email which contains the case id in subject line). The case handler (Lucian) is very smart, he has resolved many previous issues we have had, but the system of emails and responses seems to be confusing.

I have personally sent 4 responses with our case details, but we keep getting #Case Reminder 1, 2 auto generated emails telling us, “If we do not hear back in the next 2 working day(s), the case will be auto-resolved.”

Very ironic that we have to get support on a support case now. Inception in short :slight_smile:

Case ID : 01812526 Packing of windows version projects in AzureDevops


We found out that this bug was resulted by how Azure Agent and the older UiPath Devops stages used to depend on a specific file containing the full path to necessary dll for the CLI package to run on self-hosted azure pipeline agents.

There are two solutions

  1. Before the bug fix from UiPath Azure Devops team
  • Update the agent version of your self-hosted azure pipeline agent
  • Navigate to the azure agent and to x64 folder. The x64 folder contains a file called WindowsManifest.txt containing a bunch of file paths to DLLs. Copy this file and paste on the parent directory where you find the x64 folder.
  • Rename the file to WindowsPlatformManifest.txt
  • Now the UiPath CLI will work as expected in your CI pipeline
  1. After the bug fix last week by UiPath Azure Devops team (this is a hotfix, which means you do not need to perform any action in Azure DevOps or on your pipelines)
  • Update the agent version of your self-hosted azure pipeline agent
  • Run the CI pipeline to test if your windows version project is packed as intended

We have test both the above solutions and both worked for us. But as I said, Solution 2 has overwritten Solution 1, so you do not have to go through all that trouble @ThomasStocker and team have provided a fix already :slight_smile:

Not to forget Lucian from the customer support team, thank you for your efforts as well.

I will close this thread and mark this post as the solution.


We heard that the last weeks hotfix to Azure DevOps had to be retracted due to unforseen induced bugs. So for now we have rolled back our approach to the First solution.

Our workaround is simple we use the CopyFiles stage in our CI pipeline and overwrite two files to the required source folder. uipcli looks for both WindowsPlatformManifest.txt and WindowsPlatformManifest.txt in the C:\agent_work_tool\uipcli\21.10.8319-10920 folder, our agent folder is called “agent”. This is a temporary workaround until the hotfix is re-released by UiPath (@ThomasStocker)

When the pipeline is run the C:\agent_Work_Tool\uipcli\21.10.8319-10920 folder is updated like so

The uipcli now can use both of these manifest files to pack windows based UiPath projects.

Yes @jeevith, we already have identified the issue and have the fix available with us, we have planned to roll-out this with our next release v2.12 in early week of november.

Will this thread be updated once the fix is made available? We are now past mid-November and our version of UIPath Pack in DevOps has yet to update from 2.11.etc.

According to the tracking I can see on this topic, version 2.12 should fix this issue.

Have there been any updates to this issue? I’m still unable to successfully build a project for Windows in DevOps pipeline using the UiPath Pack task version 3. I’m using the UiPath Install Platform task version 3 as well, with CLI version 22.10.8438.32859, however it fails to find my custom libraries referenced in the project which are sitting in Orchestrator.

I read that uipcli version 23.6.8581.19168 has a fix for this issue, however this version doesn’t show up as a selection in the cli version choice, and I can’t seem to get specifying a different path to the nupkg field to work properly. How do I define the path to the nupkg file/folder I’ve downloaded and extracted on the machine the agent is running on?

I’m facing a simular situation and I’m confused…

note1: my On-Prem Orchestrator is 22.10
note2: Two seperate pipelines:
#1 => Does the setup: UiPathInstallPlatform
#2 => Does the pack + deploy in seperate yml file, that does NOT include a “UiPathInstallPlatform” task

For pipeline #1
If I go for: UiPathInstallPlatform@4 (default)

- job: installPrereqs
  displayName: install preReqs
   - task: UiPathInstallPlatform@4

I get : C:\agent_work_tool\uipcli\23.6.8581-19168.
But as the package was created under 23.* and my Robots are at 22.10 as they run the package they can’t find the files needed: Could not load file or assembly ‘UiPath.Platform, Version=’

If I instead go for: UiPathInstallPlatform@3
the result is: C:\agent_work_tool\uipcli\21.10.8319-10920
And I can’t build it:

Detected schema version 4.0
uipcli.exe Error: 0 : NU1202: Package UiPath.UIAutomation.Activities 22.10.4 is not compatible with net5.0-windows7.0 (.NETCoreApp,Version=v5.0). Package UiPath.UIAutomation.Activities 22.10.4 supports:

  • net461 (.NETFramework,Version=v4.6.1)
  • net6.0 (.NETCoreApp,Version=v6.0)

So instead I also tried to pinpoint a specfic version:

- job: installPrereqs
  displayName: install preReqs
   - task: UiPathInstallPlatform@4
       cliVersion: 'WIN_22.10.8438.32859'
       cliNupkgPath: '$(Agent.ToolsDirectory)\nupkg\UiPath.CLI.22.10.8438.32859.nupkg'

And I get:

But as I later (in template yml file) call the pack command:

    - task: UiPathPack@4
        versionType: 'ManualVersion'
        version: $(Build.BuildNumber)
        projectJsonPath: '.\${{ parameters.RepoSubFolderName }}\project.json'
        outputType: 'None'
        orchestratorConnection: dev_orch
        outputPath: '$(Build.ArtifactStagingDirectory)\Output'
        runWorkflowAnalysis: '${{ parameters.runWorkflowAnalysis }}'
        traceLevel: 'Warning'

That action download the “wrong” (too high version)
I get this in the log:

cli selected WIN_23.6.8581.19168
CLI downloaded successfully, extracting…