Browse File for Upload-Click Open does not return the file name

browser
file
studio
attachment

#1

Hello,

I’m trying to select a file to be attached while I create an entry for Invoice Submission in Ariba.

  1. Open Browse to select file
  2. Type Into “File Path/File Name” in FileName text box of “Choose File to Upload” window
  3. Click Open Button

Following two activities handle the step 2 and step 3.
image

Issue I face is, along with main workflow, clicking open does not return any file to be uploaded

To test if anything is wrong in the activities, I executed these 2 activities separately. And it works fine. So, I maintained them separately and used Invoke Workflow file. But nothing positive with this approach.

Please help me solve why this is not working if executed along with main workflow to upload the attachment.

Other posts on similar topics didn’t help.


#2

@mykar88, Not sure about the following suggestions, let’s check if it corrects the err.

  1. Use Set text activity instead of type into or set some reasonable value in Delay between keys of type into activity.

  2. Check if the selector is reliable (no dynamic idx)

  3. Confirm Wait for ready has been changed to Complete

Regards,
Dominic :slight_smile:


#3

@Dominic This activity, of choosing file and opening to attach, works when executed separately but not along with complete main workflow.

  1. Tried Changing Delay between key - 1 to 15. Nothing changed much
  2. No dynamic elements in selector
  3. Changed from “Interactive” to “Complete”- but didnt work

Please help me out of this. I’m clueless.

@ddpadil @aksh1yadav @ovi @ClaytonM


#4

Hello there,
saw this issue once. I think it due to multiple consecutive attach window/browser inside one another (though it has same or valid selector).
Try using UiExplorer and get full selector for each activity and give a try.

If still same issue. Please attach workflow.


#5

Hi,

My question would be where does it get stuck? I’m going to assume that you can bring up the Open dialogue window and it fails to type in the filename. My suggestion would be similar to ddpadil to check on the selector, and maybe try using an Attach Window for the Open dialogue window and a partial selector for the TypeInto inside the Attach Window. I have fixed many issues doing that.

I would also recommend removing the Click Open button activity and add the enter key to the TypeInto activity. For example, filename+"[k(enter)]" since enter will also click the Open, or should.

Regards.


#6

Sure @ddpadil. Will post xaml if there is an issue after using full selectors


#7

HI @ClaytonM,

Issue is with click activity.

On opening the Opening dialogue window, I’m able to type the file name but on clicking the open button, it does not return the file name (with path), to allow me attach it to the invoice entry.

Tried using file + “[k(enter)]”.

Activities inside Open dialogue works perfectly while executed separately (kind of unit testing). But along with main workflow, it fails only to open/ return the file path which needs to be attached to invoice entry.


#8

Hi Dominic,
I have the same issue as on web recording, The open dialog box open, but on run the test the same dialog box not open, can i get a solution to this .
As i tried the solution provided by you and also tried many other ways but not get any solution to this.