Typing in file name does not work in background


the attached (should enter file name in iexplorer box opened by a webpage to upload document) does not work as soon as I select simulate typing or send window messages. it does not give me an error, just stops and hangs forever.

without simulate or send message it works perfectly fine.

I am developing right now and executing from studio 2018.4.5 on Win10, if that helps


TypeinvoicePDFname_.xaml (8.4 KB)

Hi @AlexJank

Welcome back to uipath community
kindly put all these inside a attach browser or a open browser activity and try to run it
the way you were using with simulate type is correct
Please go ahead and check whether this works or not and let know for any queries
Cheers @AlexJank

hi @AlexJank,
I have seen the workflow ,the activities had ,they are not full selectors , it is partial selector which will be generated if you use a click activity inside a attach window or attach browser.Try clicking outside of them which gives you a full selector.And one more thing there are some fields which you cant directly type into in that case use click activity in the field(it activates the field )and just use a type into without any selector.
Hope it helps.

Thank You

1 Like

hi, thanks, but it did not work. actually I moved it out of my browser workflow to see if that works. it is the same it works inside or outside unless I activate the simulate type…

1 Like

kindly run in debug mode so that we would come to know the error on where it occured and why it occured, and once done, share those details pls
Cheers @AlexJank

thanks, it seems this worked! I just copied the same selector to the click activity and removed from type activity and it worked in simulate mode!

no idea why, but it seems to have helped, thanks again :smiley:

1 Like

yes, that was the problem, the debug just said activity opened, closed… no error, strange. thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.