BOT Running very slow on Internet Explorer

Hello @ClaytonM , @andrzej.kniola, @ovi

This problem seems to be occurring with multiple web sites.

But I am unable to figure out , the same UiPath work flow when we run on a different system (Win 7 Lenovo T460) ,
works like charm and creates no delay whatsoever.

I dont understand why is it not working on the original Laptop (Win 7 Lenovo T460) and both the laptops have same configurations.

Could it be system specific issue?
If yes , could you please advise how do we progress with this.

Warm Regards,

Ptrashant Singh


What if you try setting the WaitForReady property from Interactive to None?

Tried it, didn’t make a difference on any level that can be set.

1 Like

Hi @ovi, @andrzej.kniola ,

Thank you for giving your suggestion this topic :slight_smile:

I have tried to format the System and installed a Windows 7 OS again.

After that, I installed UiPath again on the same system and now it is working smooth.

I don’t really see any delay as such and it works like a charm.

Warm Regards,

Prashant Singh

any solution for this issue.
even though UiPath can find the web element, it uses all the timeout time that it has. as a standard 30 sec, if reduced to 2 sec, it will do the action after 2 sec. this is not optimal.
error is in 2017.1 SP1

1 Like

We tried to perform similar steps at our end but could not replicate the issue.

Could you please confirm if this is limited to single process or to all the website in IE.

Can you test with any other website like google or amazon etc to see if you face the same issue.

Also can you test with any other browser if you find similar kind of behaviour

This is required to check if this issue is limited to a particular environment , browser (in this case IE) or technology specific websites.

We tried using the WaitForReady=none option and it fixed the issue.



Yeah, I would say the problem is actually the WaitForReady = INTERACTIVE property.

I saw the same slowness problem in one portion of one screen in the application that was being automated.
In some cases, when it was changed to COMPLETE or NONE, that fixed the problem,
but what the option had to be seemed to depend on the computer, so maybe the UiPath or
Internet Explorer version was different.

The portion of the web page, where the slowness appeared, seemed to be dynamically generated, so
maybe this has something to do, with the page or element loading on webpages. I would have expected
though that the INTERACTIVE option would have been the fastest, instead of the slowest, since it waits
only for a portion of the page to be loaded as far as I know.

I have no clear specs, but this is known about the systems, where this problem occurred:

Browser: IE11
OS: Windows 7


I have exactly the same behavior at the the same exercise (Download monthly report). In the beginning it runs fine. In my case I used an example that had no reports available up to July. Then at July it finds a report, downloads it and every action after that is slow and takes roughly 30 seconds.

Weird thing is, if you Stop (F12) the workflow during execution and try to run it again from the beginning, it will then be slow from the beginning (so also Jan - June in my example). To reset the whole machine, you then first need to Close Internet Explorer AND UiPath Studio.

Could there be some bug with the For Each loop or the activities inside the Else part?

WaitForReady=None seems to speed up again, but Interactive and Complete sometimes necessary (e.g. Vendorinformation in the training environment).

@ovi Testing on Windows 7, IE11 and Studio 2017.1.6522

I am facing the same problem. However, it got solved by setting WaitForReady = None. This is probably just a temporary solution, or could this work long-term? What are the drawbacks of using this “quick fix”?

When downloading monthly reports from, it suddenly get a lot slower.
Windows 10, IE11, Studio 2017.1.6522.


@ovi @Bolletje @andrzej.kniola

I ran into the same problem and immediately I say, “Windows Server 2008 R2” and “IE11”
It is clear that the problem is “IE11”

The operating system does not matter

1 Like

Thank you all for this discussion. I have been breaking my head for weeks to figure out the issue. As most of you have isolated that this delay is happening once we have interacted with a file download dialogue. Quite surprised to see that this issue have not been resolved yet!

1 Like

hi, i haver the similar problem, but for example, when i run olnly this (System1_CreateYearlyReport.xaml (32.2 KB)
)process for create yearly reports whitout the main process. it was executed perfectly, and it was created this report, (Yearly-Report-2017-FR065748.xlsx (8.0 KB)
) i dont know why failed when excecuted the main process

I have the same problem.

I have also the same problem…very strange it’s not solved however it’s reported long time ago

1 Like

@Jaume_sg, @ktaha2

For me the problem was solved, once I formatted my Windows OS and had a fresh installation of Win 7> installed UiPath on my laptop again >worked fine for me ,

I have already mentioned in my above post.

1 Like

I’ve had this happen to me to on Windows 10. It just randomly decides to go slow. I am running a single xaml file and the first Type Into took about 30 seconds to achieve. I am using the Acme “Download Monthly Report”. The first iteration of the workflow execution, although I ran it before through its full cycle.

Same problem over here :frowning:
Every interaction with the ‘Reports - Download Monthly Report’ page takes up to 2 (!) minutes. The rest of the bot runs smoothly.

Hey, UiPath-people, I cannot afford that amount of time!

This is classic issue. There are ways to overcome this slow response behavior. :wink:

I’m facing the same issue. after downloading the first file the UIpath is taking very long time to find the elements and perform the activities inside the browser but the activities related to Save window are faster. (Activities related to browser are very slow)