Background process fails to pull assets from Orchestrator

We have a Background process that runs every 5 minutes. If the Bot is not already signed into its VDI, this process will get “stuck” indefinitely trying to pull assets from Orchestrator. The job will not fault; it will just continue to seemingly “hang” in the middle of our Init State for as long as we let it.

When we sign into the VDI as the Bot and disconnect from the session, effectively leaving the Bot authenticated in the machine, the Background process works. All assets are pulled, and the job does not get stuck or hang indefinitely. It takes a matter of seconds for the job to be completed.

Currently, we’re working with Assistant 23.4.1.

Any ideas why this is happening when the Bot is not signed into the VDI & does not happen when it is signed in?

Check if you are using the Console Session in your robot or the RDP. From what I see in your description, it seems you are using the Console session, or a not configured RDP setup for your robot.

Check these:

We have “Login to Console” in the Robot Settings toggled off because if we toggle it on and set it to “No,” we get the following error, and the job faults:
“Could not start executor. RDP connection failed: Message: An authentication failure aborted the connection.”

(We were having screen resolution issues with our Bots, too, so we tried to follow the guidance here: Update Resolution Settings For Robot - Runtime Screen Resolution - News / Knowledge Base - UiPath Community Forum
That’s when we turned “Login to Console” on and set it to No. When we started getting the error I pasted above, then we turned it back off and edited the UiPath.Settings file on the machine itself. That resolved the screen resolution issue.)

Hi @Joe_Matuch ,

On the error mentioned, was the below post checked :

I’m not sure on this point. I don’t have line of sight to what the Platform team is doing. I will keep this idea in mind for resolving that error, though.

Still not sure why the Bot has to be signed in to the machine to run the Background process successfully. We followed the steps listed here under Running Background Processes: Robot - Background Process Automation (