AzureDevops Artifact feed - connect to studio for nuget packages

Hi all

I have developed some custom activities with Visual Studio.

I have the codebase in a repo on Azure-Devops.

There I have created a pipeline which in the end creates NuGet packages and adds them to the artifact feed.

Now I’ve been trying to connect the artifact feed to Studio in the settings section of ‘Manage Packages’.

I’ve already tried adding authentication in the ‘NuGet.config’ file, but to no avail.

An entry gets added but the packages do not show up.

Yes, I am aware I can add a local folder with the NuGet packages in, but I do not want that.

Because when i update the codebase and generate new packages via the pipeline I want everyone in the company to have the option to update to the newest version of the package they are using.

Many thanks in advance!

Kind regards, Benjamin.

See it

Hey @Benjamin_Degryse

Do you have a source link please?

Thanks
#nK

Hey @Nithinkrishna

I don’t see why I would have to share a source, as this is Azure Devops, YAML related? :slightly_smiling_face:

Kind regards, Benjamin.

No @Benjamin_Degryse

I’m just clarifying if your source link is fine which you have used ?

Thanks
#nK

Hi @lepumin

Your link was a good entry point to find all the info I needed to get it working.
Thanks for that!

@Nithinkrishna

I’ve managed to connect Uipath studio to the artifact feed.

in the post below i’ll make a step by step guide for anyone experiencing some difficulties.

Kind regards, Benjamin.

Step by step guide:

  1. Create a personal access token(PAT) on Azure DevOps
    1.1. Add NuGet authenticate task in YAML and specify the artifact feed.

  2. Add the name of the PAT as username and the token as PW in the NuGet.config file (see this link for more info: NuGet.config File Reference | Microsoft Docs
    !! make sure to use ClearTextPassword if it’s clear text)

  3. add the feed to the studio:
    3.1. via manage packages
    3.2. Settings section:
    3.2.1. click add
    3.2.2. fill in name (make sure to make the name match with the artifact feed (see link above why)
    3.3.3. add the index.json url as source ( in devops go to Artifacts then click connect to feed
    next click on nuget.exe
    (the value (is the index.json), you can add the entire packageSources node into the nuget.config file but do remove the clear tag from the ms guide (first link))

Steps I also took which might have helped indirectly but not sure

  1. installed Azure CLI
    1.1. added the devops extension
    1.2. logged in AZDevops via the cli
    1.3. if the normal login did not work : use this: az login --allow-no-subscriptions

  2. Reboot after AZ cli install & setup

  3. in nuget.config:
    3.1. also added package restore info from ms guide (first link)
    3.2. also added packageSourceMapping (first link)

  4. Used NuGet package explorer ( NuGetPackageExplorer/NuGetPackageExplorer: Create, update and deploy Nuget Packages with a GUI (github.com))
    and signed in via that also.

If anything is unclear tag me in your reply, and I’ll try to help you out where I can!

Kind regards, Benjamin.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.