Attach Browser error in Assignment 1 Level 3

Getting Attach Browser error while running the assignment in System1_Close.xaml.

"Attach Browser ‘iexplore.exe ACME’: Cannot find the UI element corresponding to this selector: "

1 Like

Can you please attach the xaml or screenshot so we can zero in on the exact problem.

HI @suruchi120294

Have you tried using WildCards?

try this

<html title='ACME System 1 - *' />

Thanks,
Prankur

2 Likes

@Ashraya Please find the screenshot

I think the problem is with selector.

Most probably the issue is when this workflow is getting executed, the browser is not in the dashboard page so the selector is no longer valid. You can try replacing the the word “Dashboard” in the attach browser selector by wildcard *, It should solve your problem.

P.S. refer to the attached xaml

Logout.xaml (7.0 KB)

1 Like

Check if you have selected the correct browser in Attach browser. (Chrome/IE)

1 Like

Done. Using wildcards .:v::v:

Tysm . got it :grinning::grinning:

1 Like

getting this same error again.Now what to do ??
Sometimes it works and sometimes it gives error.

i have been doing this assignment in IE explorer.

1 Like

Can you show us your selector for Attach Browser activity?

is ur uipath is latest version or old version???

bcoz i am getting the same issue with the selectors
sometimes its runs and fails later

Latest Version 2018.3

@PrankurJoshi
This is the selector for attach browser in System1_close file

same issue here ms suruchi
as i am working chrome and mozilla
but fail

Its not a issue with the version of your UiPath.
Can you check if your selector is correct?
Also are you getting the error for the same action?

Sometimes, end process runs but your Acme site is not actually open so it will throw an error.
So either use a condition or make continue on error to true

hey nadim
i am making selector like 100 times it works and fails again

Error1

Not sure but why are you using tag=‘BODY’?

Hi,
Having the same problem also, i tried everything but still have the same error