Assignment 3 dispatcher on element selector

studio

#1

Hello i am blocked at the first part of the dispatcher when we have to add the “on Element appear” activity. I’ve been looking on the forum, some people seems to have problem at that part.

it keeps showing me
{
“message”: “On Element Appear suivant: Activity timeout exceeded”,
“fileName”: “Process”,
“logF_BusinessProcessName”: “Framework”
}

here’s the selector, it’s driving me mad :exploding_head:

thanks


#2

Hi @grish

You haven’t checked either ‘wait visible’ or ‘wait active’. Please check and try once again!!


#3

hi @ChagantiAkhil thanks for the reply.
Even with one or the other of those options i’ve got the same error.


#4

I think i misinterpreted the question. Let me edit this answer…

Selector looks fine. If in doubt, examine the element with UiExplorer.
This is likely an error because of WaitForReady property. Try setting it to INTERACTIVE.

Sample Workflow attached.
Process.xaml (12.7 KB)


#5

it still doesn’t working


#6

Selector not fine! :rofl:

You typed htlm instead of html. Try again!


#7

it doesn’t seem to be the problem xD


#8

I don’t know what the problem is then, sorry.

Try imitating the workflow I attached earlier and let me know what the issue was, when you fix it. :man_shrugging:


#9

thanks for trying pal :wink:


#10

Try making the page number is visible when On element appear activity is reading the data (i.e, like adding a click activity on current page no). Because the activity is searching for whether next page exists or not…!! In the ACME site, the page are at the bottom, so you need to scroll down…
Try it once!!


#11

i must be dumb or something because i don’t see why
@ChagantiAkhil can you look into it ?

Process.xaml (16.3 KB)


#12

Yeah I’ve seen the workflow. I think you are making your flow complex. You’ve added navigate before on element appear, passed both transaction number and transaction item. Instead of that, in the process transaction you need to extract the data add to queue. So you can make your flow like, inside the attach browser you add the on element appear (wait visible or active) and add the queue part.
I hope you got it!!


#13

hi @ChagantiAkhil, i did something like you said. it partialy worked : it adds the data to the queue but when there is no more data, it throws this error.
Sans%20titre

but those data are in the orchestrator’s queue so it’s okay no ?


#14

Did it added all the work items from all pages of ACME website to queue which met the condition !!?


#15

i checked the last one (9829044) and it’s the last one on acme, so i think it did the job ?


#16

So this happens on the last iteration. Basically when there are ten pages, it looks for the button of page 11 and can’t find it.


#17

yes that’s what it looks like


#18

If there is no next page, that means there is no transaction item. So it should not come to Process transaction state. So check why it is coming to process state?