Assign transaction item issue in assignment 1 level 3

When executing the file it starts with transaction number 2, and updating the hash value it did not types the hash code.

Initiate with value 0 instead of 1 for the variable
And try once
For type into activity with has code make sure that the variable passed has value in it
We need to check with the arguments passed across the workflow with proper IN and OUT direction

Cheers @Venkatraman

Hi it works smoothly but when comes to last workitems it tells that index was outside the bounds of the array.i tried both the inputs but nothing changed.

Try the following:

  1. Keep the TransactionNumber default value = 1

  2. In GetTransactionData apply the following to your assign activity out_TransactionItem = in_WIList(in_TransactionNumber -1)

  3. Increment your TransactionNumber after you processed the transaction

1 Like

Hi there I changed the value to 1 and actually i placed the assign activity which increments the transaction number in below the invoke of get transaction data workflow.after i moved it to the below to invoke of process workflow.i got this error

@Venkatraman, please expand your Process Transaction workflow and attach an image.

Ita has been fixed but it shows error in sha1 getting hash code workflow… selector issue in get full text activity…but the activity is under in attach browser and i tried it enabling the aaname attribute also.but it still doesn’t works