Level 3 Assignment 1 last transaction item index was outside the bounds of the array

Hi i actually completed the workflow. It works smoothly but when comes to last transaction item it shows as assign transaction item index was outside the bounds of the array…it’s really frustrating me.i am trying this for days…
And i tried using assign transaction item=in_wilist(in_transactionnumber-1).While on this, the execution starts with the Transaction number 2 instead of 1.

Hi @Venkatraman

Check this

Level 3 assignment 1 index was outside the bounds of the array


Hey @Venkatraman

While having the transaction Item in the get transaction data xaml file like this transaction item=in_wilist(in_transactionnumber-1) Try changing the default value of the transaction Number variable in the main xaml to 1. This should work for you…

Also, do one more thing, In the get transaction data xaml, just before you assign this
transaction item=in_wilist(in_transactionnumber-1),

Have a write line to check the transaction number value and the number of records available in the in_wilist…

This might help you figure out what is going wrong…

Hi the assign transaction item errro has been fixed .but it doesn’t recognizes the uielement of get hash code now.i think it’s been a selector issue.get full text is under attach browser activity and i tried it enabling the attribute inelement and aaname.but it still shows error