Assign:Object reference not set to an instance of an object

Hey there,

am doing calculating hash security exercise and am getting the following error message for one of the assign activities and I cannot figure out why.

"Assign: Object reference not set to an instance of an object
attached is the whole process, can anyone help with this, please?

RoboticEnterpriseFramework.zip (1017.1 KB)

You are trying to access an object without instantiating it… You might need to use the “new” keyword to instantiate it first i.e create an instance of it.

Example:
New System.Data.DataTable

can you detail where i can put that please, below is the screenshot of the error.

I’m checking your workflow and I’m not getting any error at all.

I’m using Uipath Version 2019.10.3

image

so did you run the workflow and you didn’t get any errors?

I am using the same version but am getting the following:

1 Like

@Hadeel_Al-Dowsh,

I’m checking. I think I know what’s wrong. Give me around 5 minutes.

@Hadeel_Al-Dowsh,

In the workflow where you extract the items, the local variable is the same as the argument. Delete that local variable since your output is being null because it’s assigning the value that you extract to that variable instead of the argument.RoboticEnterpriseFramework.zip (1017.3 KB)

Hey,

I am not sure that I got what you mean and which local variable that was deleted from the workflow you just attached. I tried to run it and it passed the previous error, but came back with this error:

In your variables panel.

Make sure dt_WorkItems is only in arguments in your Extract_WorkItems workflow and that the direction is out.

Hi @Hadeel_Al-Dowsh

Has this problem been resolved? I have tried all possible solutions. Nothing seems to work:(

Resolved!