Asset FolderPath property when using subfolders

Hi,

I am using modern folders, and have a folder structure similar to this:

GlobalAssets
BusinessProcesses

  • ProcessA
  • ProcessB

Inside my automation, deployed to the ProcessA folder, I want to get an asset stored inside the GlobalAssets folder, using the FolderPath property of the GetAsset activity.

If I use “/GlobalAssets”, I am told that the folder does not exist, or that I do not have permissions to it.

The account running the automation does have permissions for the folder, and yes, the folder exists :slight_smile:

Any ideas?

Hi @jjes

Maybe you have already tried this, but I don’t think the foward-slash character needs to be in the path.
Can you please try using just “GlobalAssets”

In my setup, I am using the modern folder equivalent of “BusinessProcesses” from your sample structure, and I am able to do this without a “/” character.

Thanks a lot, it worked!! But is it just me, or is this not documented correctly in the documentation here?

The example given under FolderPath starts without “/”

The section you’re probably referring to is the Note section, which talks about relative folder paths and X-UIPATH-FolderPath-Encoded headers, which references to building API requests. Read more here.

I hope that clears it up a bit.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.