Argument Assignment From Flowchart To Workflow

This seems simple so I don’t understand what I’m doing wrong.

  • I have a workflow (ParseICD10Orders) inside a flowchart (MLAB)
  • I select the workflow (Parse ICD10 Orders) and click “Edit Argument”
  • I create an argument called “in_OrderData” that is a string with a default string that is representative of the data that I would send it. Just as a test.
  • See screenshot one.
  • Next I go into the workflow (ParseICD10Orders)
  • The in argument is completely inaccessible from within the workflow no matter where I try to assign or access it (Variables, Arguments, assignment).

Am i misunderstanding how this works? I have been able to set up out variables that seem to work fine.

Edit: Is there some documentation about passing variables and arguments somewhere? I tried the UIpath Studio documentation but the search for “passing arguments” and “passing variables” didnt return. I might not be asking the right question though.

Thank you

The easiest way is to go into the invoked workflow. Within here click the arguments tab and create a new argument. Now, go into the parent workflow. Instead of clicking ‘Edit arguments’ you should instead click ‘Import arguments’. Now it should show up in the list. From here you can assign it the value needed from this parent workflow

Thanks for the help but it still doesn’t work.

  • I created in_DataTest within the invoked workflow (screenshot #1)
  • Navigated out of the invoked workflow and clicked “import arguments” (screenshot #2)
  • modified the arguments so the default value was “test” as string
  • drilled down into the invoked argument and ran the workflow.
  • Workflow displays a blank message box (screenshot #3)

screenshot3

Seems to be working fine for me - see the workflow files attached

Artex_Invoked.zip (2.7 KB)

I’ve created a new project and it works. I’m very confused as to what would cause this issue. Maybe I’m missing something regarding scope or layout. No argument assignment works within this project except for out variables. Very strange behavior.

Its a huge project and it looks like I’ll have to rebuild it. Any feedback or theories would be most appreciated.

@artex - it is likely a variable scope issue. An argument is the highest possible scope. If you have a variable with the same name as your argument, then the value shown will be the lowest scope possible. This means your message box activity could be showing the empty variable instead of the argument that contains a value.

Best way to debug is to step through it using debug mode and check the value of that argument the whole way through