Anchor base activity + Click Link

Hi am working on automating an SAP application.

This application opens inside a browser. Here I have to click on a link based on the location in the table.

The table looks like this.

I use Anchor Base right
Find Name, Click contract No
I have used Anchor Base activity and it worked fine with Internet explorer.

When I use the same activity and in Edge browser bot is unable to click on the link in the first column.

this is the selector for the link in column one I am using.
//"webctrl tag = ‘A’ "

When I use it outside of the Anchor base activity the selector clicks the link but It is not inside anchor base activity.

Need help with this.

Hi @Sairam_RPA ,

Could you try refining the selector of the Click Activity to include the Column number as well?
That is what I usually do, and then pass in the text I want to click in into the innertext(if its available)

It really depends on what the UI Explorer is able to capture and display into the Visual Tree.

The more UI Elements we have, the more flexible we can be with our Web Automations.

Kind Regards,
Ashwin A.K

To find the name value this is what I use:

//webctrl tag = ‘SPAN’ aaname = ‘" +InputValue+ "*’ //

I only have the input value I don’t have another values. Based on this input value I am able to validate that the value exists.

To click the link in the Number column I am facing issues.

Is there a way to get other attribute values If I only have the single attribute value to match to ?

Hi @Sairam_RPA ,

So what you are saying is that the UI Explorer is able to successfully Highlight the element, correct?

Then you could try enabling SendWindowMessages and see if that works out for you?


If you are using Modern Activities, then you could play around with the following options:


Chromium API works well for Edge and Chrome, Simulate is alright, and Hardware and SendWindowMessage has to be your last resort.

Kind Regards,
Ashwin A.K


I tried adding the //webctrl tag = ‘A’ tableCol= ‘1’ // This did not work.

I tried using send windows messages and simulate click - It does not work.

What I was saying earlier is that the code worked fine in Internet Explorer web browser.

Now we are supposed to use Edge browser, while migrating to Edge browser I am facing this issue.

Further When I try to use the click activity outside the Anchor base activity bot is able to click the link. Inside the anchor base activity it doesn’t click the link.

Hi @Sairam_RPA ,

Can you give a try by using click activity and mention anchor in the same selector like in below screeshot.


I gave the full selector in click activity inside anchor base activity. It still dint click.

Not sure what to do

You should switch to Modern and use the new activities that include anchor functionality, fuzzy selectors, etc all in one place.

I was able to solve the issue.

I removed the anchor base activity.

  1. Used the Find Element Activity.
  2. Output came as uielement.
  3. Got the required attribute “rowName” from this.
  4. Passed the “rowName” attribute to click activity.
  5. I am able to find the element in this table and click it.

Thankyou for all the suggestions


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.