Alteryx Integration Activities - Now in Public Preview!

We’re happy to announce that the new Alteryx activity package is now in Public Preview.

:bulb: Please reply below and tell us what you think! Your feedback will be critical as we drive toward GA release.

:bookmark: Overview

Simplify automating processes that use Alteryx Server by replacing UI operations with background API calls.

Alteryx customers can now manage apps, jobs, and output directly from a UiPath Robot. The package provides an integration between UiPath and Alteryx Server that permits the usage of key functionalities that are most likely to be used in automation.

This package includes the following activities:

· Alteryx Scope: provides authentication for Alteryx services and all activities.
· Get App
· Get App Jobs
· Get App Questions
· Get Job
· Get Job Output
· Run Job

:hammer_and_wrench: How to install

In the Official feed, check ‘Include Prerelease’, search for “UiPath.Alteryx.Activities”, and install the latest Preview version.

  • :exclamation: Important - Please make sure you check the ‘Include Prerelease’ checkbox

:film_strip: Getting Started (Guide + Demo)

Check out the demo below and the user guide to help get you up to speed fast.

6 Likes

This is gonna be a banger, thank you so much

2 Likes

If you provide us information or link what is Alteryx and what activities are carried by it currently, we can better relate this reveiw. Can we keep small description before in this Public Preview template for learners perspective.

This is what I have been waiting for so long. Thank you!

1 Like

This is great!!!

Can we itegrate uipath directly with Alteryx designer?

As to authenticate we need to provide API key and secret and to provide API key we need to have Alteryx server access.

Thanks,
Priyanka

1 Like

At this time the activity pack only integrates with the server, however you can always use UiPath to automate the UI via UI automation.

This is great stuff,I was looking for it,I am trying to test it,but I am facing an issue while running my Alteryx workflow.
My Alteryx workfow is simple no input question and no output just for testing purpose.

I am able to get the app id using Uipath Alteryx activity,but it fails to run the app id as job using Run Job activity.

Getting RemoteException wrapping System.AggregateException: One or more errors occurred. —> RemoteException wrapping UiPath.Alteryx.SwaggerException: The HTTP status code of the response was not expected (500).

Appreciate any help regarding this.

Thanks!!

Hi Sid – we’ve tested that scenario and it worked. In order to diagnose, we’d need the log file of the robot.

Hello paul.hoeffer I have sent you the logs in a mail.

Thanks.

Thanks – we’re taking a look at them today.

Hi SId,

We looked at the 2020-08-18_Execution.txt. We are receiving a 500 error code from the API call, so the failure is happening on the Alteryx side. Are you also passing in the Priority to the Run Job? Is this something you can look into on the Alteryx side?

02:36:46.0377 Error {“message”:“Run Job: One or more errors occurred.”,“level”:“Error”,“logType”:“Default”,“timeStamp”:“2020-08-18T02:36:46.0417038-05:00”,“fingerprint”:“691f53f9-e28d-43e6-8b10-2fc58e3ce9dd”,“windowsIdentity”:“EAGLE\svcRPAIMSDev03”,“machineName”:“HOUCTXUIPDMNT03”,“processName”:“alteryxApiCall”,“processVersion”:“1.0.0”,“jobId”:“9b9edc62-e4f9-4be6-98b3-d5c4cabc5e5a”,“robotName”:“rb_ctxt03_dev03”,“machineId”:36,“fileName”:“Main”}

Regards,
Bhushan

Hello Bhushan.Khadpe,

I have sent you the screenshots in the message.

Thanks

Thank you for sharing this demo!

I try to follow up along to build the same use case,

Everything looks good before “For Each loop” after “Get Workflows”,

I tried to loop over Workflows (Output from Get Workflows activity) and access item.Id , but I got an error message:

Compiler error(s) encountered processing expression “item.Id”. Option Strict On disallows late binding.

Do you have any ideas on how to solve this?

Also, it would be nice if you could share the XAML for the demo,

Thanks!

Kun

For the data type of item, do you have it set to UiPath.Alteryx.Workflow?

Hi! For the ‘Get Job Output’, I’m having trouble getting the output to actually save as a pdf. For the ‘Format In’ section of the activity, I’ve tried “.pdf”, “.PDF”, and “pdf”. None actually result in the file being saved as a pdf even though the process executes successfully. Any recommendations?

Hi - can you please post the XAML file so we can see better what you are doing? It will help us understand the nature of the issue.