After Studio upgrade accessing any Java Application does not work anymore

Last week we updated Studio from 19er version to latest 20.4.3 Stable.

But sadly one of our process that is interacting with a Java Application (called Nuclos) is not working anymore.

With not working I mean that I can not selector a field anymore. As you can see from the image, I would like to click into one of those both fields. Before I upgraded I was able to do that… but now it selects me always the whole window.

Maybe you have an idea about that?

Btw I use the package in version 20.4.2 which is also the latest.

Hi @kwoxer,

Try re-indicating your Attach Window scope if you are using one. One of my processes uses a Java Application and when the application updates, I have to then update my UiPath Java Packages.

Attach Window scope is not the reason. I also created a whole new Process with only an Attach Window and click activities. No change.

What you mean with updating Java Packages?

Hi @kwoxer,

Do any of your selectors validate?

What I meant by the Java Packages is the Java Runtime Plugin available under Tools > UiPath Extensions on Studio.

Ohh that’s a good hint. I think that Java Integration Extension is the reason.

But I just reinstalled it, and restarted my PC, but no change.

Still the old selector is not recognized and it say “Not valide”.

I for sure also tested to update the selector. But I’m still not able to select the Textfield. Instead it selects the whole window.

I think my issue is that the old Java Extension was still installed. And I need to somehow clean my system from the old Studio and Extension.

Do you have an idea how to do that? Or is this the wrong way to check?

Hi @kwoxer,

The issue I had sounds very similar, in which the entire window was being highlighted when the selector previously indicated a textbox. I didn’t delete or remove any instances of packages or extensions.

I re-indicated my current Attach Browser and then a message box appeared, which said something about updating Java Packages (I can’t remember exactly what it said as this occured a few weeks ago).
I clicked OK on it, and then restarted my UiPath and everything seemed to work fine. I also altered the selector so it was generic and would attach any instance of a java application being open.

1 Like

re-indicating means that you clicked again on the “Edit Selector”, correct?

As I said I did that already and had no change.

Also there is no Popup coming up here, sadly.

But I think the version of the JRE could be the reason. Could you tell me which version you run at?

Hi @kwoxer,

Yes, re-indicating means going on Edit Selector and then indicating the element again.

Here is my version:

Ok gonna try a newer (your) version.

No change. Also restarted PC.

And it’s not an issue of any used selector. Also when I use the “Recording” tool. It simply selects the whole tab window of my Java Application.

No chance to get into a single element anymore…

I think now that it can only be the issue of the UiPath Java Platform tool.

How to delete that package completely to have a fresh reinstall?

This exe is used when the Installation starts

C:\Users\decurmos\AppData\Local\UiPath\app-20.4.3\UiPath\JavaSupport\ScreenScrapeJavaSupport.exe …

but I cannot see an issue of that installation command. I’m out of ideas.

Someone else with any idea?

Hi, Have a good day.
I have the exact same problem as you.
After using the latest version of Studio, I also couldn’t select individual elements, only entire Windows.
If you have a good solution or have solved the problem, please contact me.

@kwoxer , what was the old selector? What is the new selector you get when all the window gets highlighted? If you are using the UiExplorer, are you manually able to expand nodes until you reach the text field?

I currently do not use Java applications anymore as these bugs were too heavy. I swapped to a REST interface. So I cannot longer test something here.

But what I can say is that it did not work properly with Java application. Most elements like a table in a subcontainer were not available. Just test with subcontainiered Java application. I am sure you find that issue on you own. Good luck and hopefully you fix that soon, otherwhise Java apps are not practicable to use with UiPath.