Advice on running an xaml in another server

I created this project that opens a chrome browser, loads a URL and then downloads charts from there. The url is generated by a python script and it doesn’t have reliable selectors, so what the bot does is to use anchor blocks and click on the download logo of each chart.

This runs perfectly when I run it manually. However, I want to schedule this to run at a certain time everyday. We have this scheduler that runs an xaml based on a certain time. However, it doesn’t run the said xaml while it is able to run others properly.

I suspect it’s because of how the source is generated and may need an open screen, but not sure where to start looking for the problem. Any thoughts on this?

The server btw is in AWS, if that’s a significant consideration.


Do you have any error (message)?


It doesn’t show this but in our excel monitoring file, it says failed to run process.

The file is expected to run even if I’m not logged in the AWS server though.


Do you trigger the process from UiPath Orchestrator? And do you have Unattended robot license?


I trigger it locally in the AWS server. I opened the UiPath assistant and the process doesn’t seem to be there. Do I need to do something in orchestrator for this?


From the view point of license, unattended license is needed to trigger process without user action. And we can easily trigger it from orchestrator with proper unattended settings.

From the technical view point, we can run process using UiRobot.exe. And perhaps you should check output from the command (standard output, standard error output etc) and check execution log etc if it won’t run.



So, you are running the xaml in another server as Attended mode
Check if your Assistant is connected to Orchestrator?
And also check you have the proper license


The problem in here was that I was running the xaml in another xaml via ‘Invoke workflow’, and the error occurs due to incompatible package versions - so not really about the ‘server’ in which it is being run. Thus, after aligning package versions, this fixed the problem. Thanks everyone for your efforts in helping!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.