Advanced training 3 - Add log field problem

Hi There

I get the following error in the initallsettings WF

This is the value in there:

What is wrong - Thanks :slight_smile:

1 Like

Buddy kindly check once with the value of Config(“logF_BusinessProcessName”) has NULL VALUE in it
this error occurs usually because the object we used has no reference means literally no value from the place where it refers
Hope this would help you
kindly try this and let know buddy
you were almost done
Cheers @ColinCrabtree

1 Like

Thanks for quick response :slight_smile:
I don’t really know what this is used for so not sure what value to put here and how it affects the project flow:

2 Likes

Buddy you can get to know the description of each name in the same excel buddy
no worries
this log field actually tells us the if we have too many processes in our workflow and whenever an exception occurs in any of those processes, we can name that exception that this process got exception and the term this process is mentioned in a common name, a business process name…buddy
so wherever we get error in our process we can get the log field with value of message stating us the common business name

thats what buddy, so you can mention any value you want out there in the config with a name you want buddy
Cheers @ColinCrabtree

any issues still buddy @ColinCrabtree

Hi Palan - ok I now understand the use of that variable. But I don’t know how to check if the config values are null.

I see the initallsettings WF reads the Xcel config file and extracts all the values from each sheet and and rows in the sheet and adds them to a dictionary called out_config. But get transaction item refers to in_config(OrchestratorQueueName).tostring.

I am not understanding the difference between “config”. “in-config” and out_config" and think I am getting issues with referencing

Buddy kindly check whether the config argument is passed to this workflow
and the difference between config, in-config, out-config all defines the direction of the arguments been passed from one workflow to another
here config is the global variable been used all through the workflow
in_config is config variable passed as an argument with in direction
out_config is config variable is passed as an argument with out direction
Cheers buddy@ColinCrabtree

oh ok ! that makes more sense to me now. let me go check and see what I can find. Thanks for all help so far. I will report back my findings. :slight_smile:

Hi There,

This is what the argument list looks like:
I know that if I remove this log field activity the WF terminates normally and the initapplications WF fires up and it gets the UiDemo path name and credentials from the config, goes to orchestrator and gets the values, opens Uipath Demo, enters the credentials and presents the main screen. It is only when it tries the get transaction item Activity that it falls over again

I still get this error - cant move forward at all

image

Area where error occurs

image

Config file entry

image

2 Likes

Buddy try to mention here a hard coded value of string “Process” here in the arguments instead of getting from Config(“logF_BusinessProcessName”).ToString and try @ColinCrabtree …if this works then there is no issue n arguments definition or if it doesn’t work we need to check with the argument passed to this workflow…
lets see whether the argument logF_BusinessProcessName is taking the value first
image
Cheers @ColinCrabtree

Hi Palan - Thanks for assisting :slight_smile:

I did what you asked and the WF is not falling over there now but still dont know what problem is. It now goes on and fall over at following point which has never given a problem before:

image

config file entry

image

Orchestrator assets

image

this is where the uidemo application is sitting on my lap top

Hi @Palaniyappan

I ran Uidemo.exe from explorer to get the login screen
I then opened the initapplications WF in studio then re indicated the login screen, published it and ran Main again and this above error did not happen. The app opened fine. Why did I have to indicate on screen again to reset the selector. I had changed nothing.

The WF now fails here:

1 Like

@Palaniyappan Any ideas on this error ?

1 Like

Thats great
Fine … @ColinCrabtree
The reason is the bot might not be able to identify the element and thus making the bot to re indicate enables the selector and the element - active as well
Cheers @ColinCrabtree

@Palaniyappan Thanks you for the explanation. Much appreciated :slight_smile:

Now all I need to understand is why the WF after opening UiDem and proceeds to Get Transaction items it fails at the point above indicated in the WF.

did that throw any error when it fails
Cheers @ColinCrabtree

@Palaniyappan yes the below error. The same one as when I tried to “add log fields” and you told me to hard code the LogF_BusinessProcessName

Hello @Palaniyappan . Any idea as to my problem above?

Regards
Colin

2 Likes

Fine kindly check with the argument passed in to this workflow or the one we get from this workflow is assigned with a value like argument Out_TransactionItem, this error usually occurs when the object we refer for value actually doesn’t have any value with it
You were almost done
Kindly check and let know buddy
Cheers @ColinCrabtree