Add ins in excel does not load

excel
activities
p_qa

#1

When using UiPath to read cells from excel I open the excel document with Excel application scope. The robot are then going to save specific cells to variables and then use add ins to run a .xla file.

The robot stops when trying to click on the add ins because it is not started/visable in excel, seems like the robot open the file to fast or something so it don’t load the add ins. Any solution to this?


#2

I am having this same issue. I have an SAP reporting add in (Excel Add-in) that shows up correctly when I manually open any Excel workbook. This is found in an excel toolbar. Other standard add-ins such as PowerPivot or Power Query are also not showing up. I’m using Excel 2010

When the workbook is opened by UiPath, that add-in isn’t showing up in the toolbar. I went to Excel–>Options–>Add-Ins–>Manage Excel Add-ins and the Add-in is showing up in the list as available and checked. If I manually uncheck, then recheck that add-in, then it shows up and works correctly. I’d much prefer the robot to not have to uncheck/recheck that add-in box every time a program is run. This tool is one of my company’s primary reporting tools as it is integrated with the general ledger (SAP).

I see there are a couple other unsolved forum posts regarding Excel add-ins and UiPath. Has anyone been able to solve them? If not, will this be addressed at some point in the future?

EDIT: I forgot to add that opening Excel using Start Process allows the add-ins to load and show-up properly. However, I’d prefer to utilize some of the features that require to it to be inside of an Excel scope activity, so this workaround isn’t ideal.


#3

Any chance there was an update/resolution. I’m in the same position w/ Excel Add-ins. I’ve tried activating the add-in via macro and calling the macro in UI Path, but having an issue where the add-in is immediately disabled once the Execute Macro step is completed.

I’m in the same boat w.r.t. wanting to leverage the Excel scope activity.


#4

Just wondering, have you tried using Open Application to open the file?


#5

Also to add, after the file is opened via Open Application or Start Process, you can utilize Excel Scope to attach to the window. (Just make sure it gets closed at some point)

I am not sure at this time with why Add-ins are not loading with Excel Scope.


#6

Hello,

I solved this by open the Excel file in the: StartProcess activity and then selected the file


#7

Seems when using Start Process and Excel Scope, the Excel Scope is opening another excel window (without add-ins).

I’m not seeing how you would pass the Excel Instance from the Start Process. Is there a step between the two I’m missing?

I appreciate the responses!


#9

hey Jeff ,

Use delay between start process and excel scope activity of about 4 secs . it will utilize that excel sheet only . Then you can do whatever you want with your excel add-ins.

But still it is a bug for UiPath excel activity as it is not able to load excel sheet with addins .
@Vikas.Jain @ClaytonM @aksh1yadav @ovi

Thanks
Ankit


#10

will investigate, thanks


#11

Hello Gabriel, do you have any news on this? we managed to interact with the SAP-excel add-ins by calling the VBA code (Macro) directly, however Uipath stops interacting with applications after that.

A solution for this will be appreciated. thanks


#12

hello, we have a beta excel package that allows injection of VBA code for Excel workbooks.
can you try it ?


#13

Can you provide the specifics on the beta and if any timing is known for approved release?

I’m looking at rewriting the macro code we have to VBA (minimal luck so far) - I’d like to ensure I’m using the right package.

Thanks


#14

Should be out soon. Have you tried it? Its version 2.3 something-beta :slight_smile:


#15

If you are having problems with BEx Analyzer. i have found that if you do excel app scope to open "“C:\Program Files (x86)\Common Files\SAP Shared\BW\BExAnalyzer.xla” then inside that do another excel scope to open the file you want it should work. I was able to open a file and run the native refresh macro in BEx.


#16

can you please explain more on this


#17

Hi Gabriel, I happen to see this post, any update on this. I do have the similar issues, I use ‘Excel for Analysis’ wherein add on gets disabled as soon as it runs from ‘Excel Scope’. I need to execute VBA macro via UiPath. Please let me know the procedure, it will be much appreciated.

Thanks
Tangy


#18

Hi Ankit,

An excel open with ‘Start process’ cannot be utilized in excel application scope activity? Have you tried this? Am I missing any link?

Regards,
Pratiksha S


#19

We have a run vba code activity, why don t you use that?


#20

Hi Pratiksha,

After Start process activity , use delay of say 3 secs and then open the same excel with excel application scope . You can use add ins then .

Ankit


Add existing excel sheet into excel application scope
#21

I use a alternative solution.
You can set up as this : for the file you want to use, right click open with, and select the SAP BEX APPLCAITION, set it as default.
and then in the UIPATH, you use double click the file to open it.
It should open the file in Bex application with Add-ins.