Can't see the Excelerator when i open Excel with uipath

can’t see the Excelerator when i open Excel with UiPath, but i can see it when i open excel manually

image

Hello @Soudios, check this out:

1.Excel Version: Ensure that the version of Excel you’re opening with UiPath matches the version where the Excelerator Add-In is installed. Sometimes, there can be multiple versions of Excel installed on a computer.
2.UiPath Process: Check if the UiPath process is running with the necessary privileges and permissions to access Excel and its Add-Ins. It should have the same access rights as a user opening Excel manually.
3.Add-In Loading: Excel Add-Ins can sometimes behave differently when loaded by different processes. Try loading the Excelerator Add-In explicitly from within UiPath using VBA code or by automating the Excel application to enable the Add-In.
4.Excel Macro Settings: Ensure that the Excel Macro settings within Excel opened by UiPath allow Add-Ins to be loaded. Sometimes, security settings can block Add-Ins from loading automatically.
5.UiPath Version: Ensure that you are using a compatible version of UiPath with your Excel version. Compatibility issues can sometimes cause Add-Ins not to load properly.
6.Registry and COM Add-Ins: Check the Windows Registry and Excel’s COM Add-Ins settings to see if there are any differences between the manually opened Excel and the one opened by UiPath.
7.UiPath Excel Activities: Ensure that you are using the appropriate UiPath Excel activities and configurations to interact with Excel. Sometimes, the way UiPath interacts with Excel can affect Add-Ins.
8.Logging and Error Handling: Implement logging and error handling in your UiPath workflow to capture any specific errors or messages related to the Excelerator Add-In not loading.

Cheers! :slight_smile:

Hi @rodrigo.simao

  1. how can i see that ?
  2. i run UiPath from my own computer for now, so i think the acces are the same for UiPath
  3. I did it but it doesnt work when UiPath do it
  4. How can i do that ?
  5. The excel version i have is this one :
    image
    and UiPath :
    image
  6. I can’t see where is when i open with UiPath
  7. i’am uising UI activity :

Probably while using UiPath to open the excel, it makes something that disappears. I’m not sure…

@rodrigo.simao
so what is the solution ?

i think i need to run it before opening excel file,
how can i run this process :
C:\Program Files\Engine\ExceleratorVBAInterface.xlam