Active Directory Users and Computers - Cannot Spy Elements or use Citrix

Evening all,

I am trying to automate a process that uses the ‘Active Directory Users and Computers’ interface. Can’t seem to spy the AD window or any elements within it. Can’t perform ‘Image Exists’ either (using the citrix approach).

Am I missing something or does Uipath not allow integration with the AD front end?

My process is roughly:

  • right click ‘domainName’
  • click find
  • type username
  • press enter
  • if user name found, double click user name
  • go to account tab
  • type full user logon name
  • click apply
  • click ok
  • exit AD

Would really appreciate any advice on how to get this working.

Thanks :slight_smile:

Found out that you have to run uipath studio as administrator in order to interact with active directory.

Basically find the program icon, right click and select ‘Run as administrator’ - problem solved :slight_smile:

1 Like

Hi Zoe,

Could you please provide your Studio version and installer(.exe or .msi)? This is to check if running as administrator is the intended behavior or just a workaround.


Hi Ovi,

Sure, i am using community edition version 18.1.2, unsure which installer was used.


hi polygon,

i have the same problem like yours, and i run UI Path as a administrator but it doesn’t solve the problem. Would you please help?

It works with active directory users and computers, is that what you’re using?

yes, it is exactly what i am using