Activate does not work; timeout; bring to foreground

So, process worked for a year with no problem then all of sudden sometimes the type into or click wont work. Always the same error, timeout; cannot bring to foreground. From the screenshot we see that the browser we are using (IE) is orange in the toolbar which means it is not active.
Sometimes the type into activities work and they have ‘ACTIVATE’ property set to ‘True’ but it does not activate the browser to foreground. I saw the same topic here on forum but all of those solution are not working (Browser not opening in the foreground). I dont think this has anything to do with the process build itself but with Uipath and IE ?

We tried basically everything (ie explorer properties,type into properties with various combinations, hotkeys etc), and now looking for ideas if someone has ?

Thanks

@Petar_Soce

You can try with Attach browser activity

Hope this may helps

Thanks

1 Like

Thanks. Its already inside attach browser

Hi @Petar_Soce

Excuse me if you’ve already done this, but have you tried restarting the PC?

I recently had the exact problem with IE-related robots from different PCs,
but when I restarted the Robot PCs, they worked again!

Yes, we as well have multiple production evironments and this is happening on only one of them.
I think we did restart it since this is an issue for a month now, but I have just restarted it now to be sure.

thanks

Yes. After restart its still the same. Interesting enough that code works when it is being called for the first time. The exception happens always on the second invoke.
(The code being invoked has two type into activities because it is doing a login on site).
The same code is being called from different production environments and they are working just fine.

Hi Petar,

I know this issue happened a long time ago. But do you know the solution or what is the cause for this problem? As it is currently happening to me as well.

Regards.

Hi

No, we did not found a solution. The workaround that we implemented last is that the robot after opening the browser clicks somewhere on the browser (some reliable picture that is always there). Click image activity.
Since then, this issue has not happened.

1 Like

So. This just came back again. After a month now its not working again. On different stage of the same process. I think I can say for sure now that the problem is that the window is not actviated because in this part the robot is sending hotkey which just goes to desktop.
Why is the browser not activated I have no idea. Even after the robot manually click on it it wont activate it.
If somebody has a solution, glad to hear it.
Thanks