Acme-test Unauthorized? Performer Workflow, Advanced Course


#1

Hi, I am currently doing the Performer Workflow in the Advanced course for Generate Yearly Report.

Why does the Acme-test app bring me to an Unauthorized page? After logging in, it goes to https://acme-test.uipath.com/unauthorized.

See file - Performer.zip (527.4 KB)


#2

@DEATHFISH

that is because post logging in you are navigating to a url that is not valid

this error occurs when the url is incorrect.

so just check the next web url you are navigating to after clicking the login button


#3

Apparently it’s cos I reset the test data and did not upload new items into the queue…

Ok so now I have different problem where UiPath cannot find the selector for Year and Month from the dropdown list when generating the yearly report

Click 'BUTTON': Cannot find the UI element corresponding to this selector: <html title='ACME System 1 - Reports - Download Monthly Report' /><webctrl parentid='searchForm' tag='BUTTON' aaname='2017' idx='2' />

What selector should I use?

Performer.zip (529.8 KB)


#4

use anchore base activity first for the year/month Label

then use the click activity with the selectors generated by default (editing the month/year field ofcourse since they change)


#5

Which AnchorPosition should I use? Not sure if e.g. Down means that the anchor is below or the element to be worked on is below


#6

I used the Anchor Base activity, still doesn’t work. Now it says activity timeout exceeded

Performer.zip (530.5 KB)


#7

in anchor base

  1. give the month label as anchor using Find element
  2. then use click activity in the second part of the anchor base (here you specify the month drop down box with a month name in selector (the aaname part in selector) )

repeat for year


#8

Already doing as described… when I run the workflow I get activity timeout exceeded


#9

that means it wasn’t able to detect the UI element. check the selectors


#10

I used a Select Item activity instead, now I get error on the Read CSV activity in CreateYearlyReport: Could not find file at (path)

Apparently even though it keyed in the full path with directories and all, IE still downloaded it into the previous folder


#11

Where are you keying the path for the file (which area/field) in the download dialogue box which appears on clicking save/save as

You need to type the entire path in the filename field itself (not just filename)


#12

My workflow types in the entire full path into the “File name:” field

It still saves the file into the previous location.


#13

That should not happen, if the path being input is correct then it will download

Log the path at each attempt to make sure your path is correct each time in the iteration. if it is it may be a browser issue


#14

Well, I’ve checked the path input to be correct. How do I resolve the browser issue?


#15

how are you updating the path for every file’s location at each file download?

can you share your path increment logic?


#16

path.Combine(Environment.CurrentDirectory,in_ReportsDownloadPath,“Report-”+in_TaxID+"-"+in_Year+"-"+month+".csv")

where in_ReportsDownloadPath is Data\Temp as specified in Config.xlsx


#17

Even when I download something previously to artificially make the download folder the same as the intended folder, UiPath still cannot find the file for Read CSV activity to merge data tables and create the yearly report.


#18

By this logic every file should be downloaded to your project directory’s Data\Temp\ folder

All files will get downloaded there. Whats the logic you want to achieve? every file in a single folder or each file has it’s on folder on download?


#19

I would like all files in the same folder as instructed by the solution walkthrough pdf

It should be downloaded to Data\Temp, but for some reason it isn’t. No idea why


#20

So where does it get downloaded to instead of the directory you specified?