Abbyy OCR Engine

no nuget exists for abbyy

Sorry couldn’t be of much help.Lets wait for others response.

In the latest version of UiPath you should already have this installed

You don’t even need to install a package.

I get the below. presume need to install something like with windows ocr, needed to install modi.

also can we use abbyy for screenscrape ocr?

Yeh I think you’re right there is a bug with this…

Also when recording you don’t have the option to use Abbyy OCR - see screenshot

@qateam can you investigate please?

Hi,

For Abby OCR activity to work, you need to install ABBYY FineReader Engine and purchase a license for it.
Regarding the fact that AbbyOCR option is not visible in screen scraping wizard we will investigate.

Thanks,
Cosmin

7 Likes

Cosmin, I don’t think that this should throw an error when someone attempts to use Abbyy OCR . There should be a warning message that says you do not have a registered version, please see this link for more information on how to activate, or something to that effect.

4 Likes

Hi Cosmin.

Thank you for clarifying the issue with the installation of the ABBYY Engine but i would like to know a bit more information if possible.

How does the Engine installation interact with UiPath Studio?
What steps are needed for the OCR: AbbyyErrorLoadEngine to stop appearing?
Does UiPath Comunity Edition work with a Trial Version (ABBYY FineReader Engine 11 for Windows SDK) given by ABBYY?
Is this a feature only for Licensed Users for ABBYY / UiPath?

Thank you!

1 Like

Pedro,

You simply drag on the engine like you do with google/microsoft.

Install Abbyy Finereader SDK

No, you must request from Abbyy reseller. Or subscribe to Abbyy cloud ocr. You can get a trial of this online

Yes. it is only for abbyy licensed users.

Thuylam,

I have done all the mentioned above, and i still get this error.

ABBYY FineReader Engine 11
11.119.49.1041111 installed and licensed given by re-seller of ABBYY
UiPath Comunity Edition 2016.2.6232

Main has thrown an exception
Message: Error performing OCR: AbbyyErrorLoadEngine
Source: Abbyy OCR
Exception Type: Exception
System.Exception: Error performing OCR: AbbyyErrorLoadEngine
Server stack trace:
at UiPath.Vision.OCR.OCRClient.ScrapeUsingHostService(OCRInput input, OCROptions options, CancellationToken cancelToken) … etc to avoid large amount of text

Thank you!

back to uipath on this one then.

Hi again,

After installing ABBYY FineReader Engine you must activate it. This are the steps that we do to install/activate ABBYY FineReader:

  1. Open elevated cmd in the folder where you extracted the archive (ABBYY FineReader) and run:
    Setup.exe /qb /v INSTALLDIR=“C:\Abbyy\FR11” SN=serialkey ARCH=x86 LICENSESRV=Yes
  2. In cmd navigate to “bin” folder in the installation folder of Abby (on my machine is C:\Abbyy\FR11\Bin) and execute LicenseManager.exe /SilentActivation /SN:serialkey
  3. Open Studio and use AbbyOCR.

Try the above and let us know if is working or not.

Thanks

7 Likes

Hi All,
Can you please provide the pre-requisites and detail steps to install Abbyy OCR in UIPATH

Thanks

1 Like

Hi cosmin

I had my license activated , ABBYY offers to activate it after the instalation and in the LicenseManager.exe it shows the entry and it shows that is activated.

The Error is the same…

Exception :

And i have done the cmd commands like you suggested, still nothing.
Sensitive info has been blanked.

Hi,

Have you modified the properties Scale and Profile of the AbbyOCR activity? Could you let the default ones and see if it is working?

Thanks

Hi Cosmin.

No i have not.

These are the “default” properties given after drag and drop. Tried with different profiles, same error.

Thank you.

1 Like

Hi Uipath.

Still waiting for a replay to my previous error.

Thank you in advance.

Hi,
We are trying to figure out what could be your problem, as on our machines is working fine.
Do you remember what version and architecture of ABBYY you installed? You must install the 32bit (X86) version and not 64bit version.

Thanks.

Hi @cosmin.sandulescu

I had installed the version x86 and x64 all together,
I have so reinstalled and only selected the x86 this time, tried to run again. same thing.

Is there any log file i can send to help speed this issue?

Thank you.

%localappdata%\UiPath\Logs Studio.log