'A task was cancelled' error while connecting robot to Orchestrator


I’ve checked the threads regarding this issue and none of the suggested solutions have worked for me. Sorry I didn’t link the threads here since I’m on a mobile device. Some of the things I’ve tried are restarting the Robot Service, logging into the customer’s enterprise network as an administrator, reinstalling Studio and Robot. A lot of other threads mention proxy settings but I’m not using a proxy.

For a bit more info on the situation at our site, our customer has a separated network. (Most to all customers in the finance industry in Korea use network separation due to security issues in the past). I know most companies abroad would prefer proxies in such a setting, but our customer chose to physically place two orchestrator servers to manage each of the two networks. One in the core and one in the DMZ. We were able to connect robots in the internal network to the internal orchestrator, but aren’t able to connect the external robots to the external orchestrator server. We’re able to login to orchestrator but are stuck at the part where we connect the robots. The error message is ‘a task was cancelled’ if you haven’t already read the subject.
I would appreciate any feedback on this issue. Also please let me know if anyone has done projects like this without using a proxy server.

hello @pathLessTaken

have a look into the below posts it might help

@Ajju thanks for the quick reply but I already tried restarting the Robot service

Hi @pathLessTaken

Does this apply? It should if the error happens upon the process run.

1 Like

@pathLessTaken did you find a solution to your problem? im having the same issue…

Sorry for the late post, I’ve been busy trying to wrap up our project. The cause was a little different in my case. APT protection was the main issue. We found the problem, informed our customer’s security partner, they handled this as an exception, and then we got the robot connected.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.