1. RPA Challenge - Dynamic Web Page - Anchor


#22

I’m late but latest with anchor base.
Working 100%.

RPA_Challenge.xaml (26.5 KB)


#24

Hey, I am trying to do the same example.But even after making changes in the selectors,its not fetching vale of each column ??


#25


#26


Well, I want to share my solution using only selectors.
RPACHALLANGE.zip (61.8 KB)


#27

I know it’s closed but I still wanted to post my version.

I liked the 2 for loops 1 to go through the rows of the data table and one to go through the column names to dynamise??? the selectors and the data to Type into so you only needed one Type into activity in that section (I copied that design as I thought it was really elegant, sorry can’t remember which one from but I’m sure you know who you are, well done!)

When I ran it on my PC I got 45719 milliseconds so clearly not the fastest (I can’t understand how the runs in around 2000 milliseconds ran so fast! I tried Strajk’s version but couldn’t get it to work on my machine to compare timings unfortunately to see whether it was my bad hardware/coding or his brilliance/supercomputer).

What did ‘speed’ things up for me was to tick the simulatetype property in the Type into activity in the GetData workflow, which meant the fields were populated fully in one hit rather than a character at a time.

Challenge1Solution.zip (30.4 KB)


#28

HI @Strajk

where should we make changes in code if the csv file has comma separated values (all data under one olumn)
rpa_hackathon.zip (1.5 KB)


#29

Hello, is it possible to automate using Automation Anywhere? if yes, Can you please give me the hint?


#30

Well I have used AA but to me this process will take more steps and in my experience will not be as reliable as this approach. ping me if you would like to talk about it.


#31

Hi all, Can anyone please explain me/ preferably post the solution on how to solve this using anchor base as @badita gave a hint? Many of us solved using only the selectors by using aaname which is very reliable and faster. I really wanted to compare and see which one is a better solution. Also, I am not sure how can we use the anchor base as the text type-in fields sometime appear below the title and some time adjacent to the title. I have tested @beesheep 's solution, It is not working when the type-in fields appear adjacent to element titles. It only works when the type-in fields appear below the titles.
Looking for a nice and deep explanation.
Thanks,
Yeswanth.