Write Range: Range does not exist (When using a "=" for adding a formula)

Good day,

I want to write a dt while using a Write Range for adding a dt with formulas to a sheet.
When using the Workbook Write Range I will get just the plane text. (Like below)
afbeelding
When hitting enter in the cell (while having Excel open), the formula is accepted. I have read that this doesn’t work with the Write Range from Workbook.

This is why I use the Excel Application Scope. I have debugged it it to the level of knowing that I happens when I use a = in the Write Range. Meaning I can’t write a formula to the sheet. Anybody any advice? Using the 2019.11.0-beta.2 version.

Kr, Paul (NotARobot)

@NotaRobot Can you send a screetshot of your write range acitvity ?

Sure @shibani!

I have tried the same with a string which gives me the same result.
Please also see the xaml for more details. UiPath_Test.xaml (29.5 KB)
Example dt.xlsx (11.6 KB)

Kind regards! :slight_smile:

Right. I faced the same issue. Solved by clearing all formats of target cell.

image

There is no UiPath activity for this. Maybe some 3rd party in GO!

Cheers

@J0ska… unfortunately this doesn’t do the trick for my situation. Thank you for your input though! Hopefully it will help others that face the same situation.

Try the following
UiPath_Test.xaml (42.3 KB)

I replaced your formulas with simple =x+x
With yours I did not make it working :frowning:

Cheers

EDIT: The problem is in your formulas - use “,” as separator, not “;”

Hey @J0ska,

Thank you so much for your input! I am still trying to figure out the rest since it only gives me #Name? although the formula is correct (changes ; into , and added a quote in the formula). Also I changed the Quote variable into “”"" which is a bit easier I think. Do you mind helping me on the rest as well?

Problem 1
The first column is correct. However, the second shows =Name? although the syntax is correct.

Column 1 = “=(Input!C” + cstr(Counter) + “-Input!C” + cstr(UpCounter) + “)/Input!C” + cstr(UpCounter)
Resulting in IF(A2>=0;“Up”;“Down”) Works

Column2 = “=ALS(A”+ cstr(Counter)+ “>=0,” + “”"" + “Up” + “”"" + “,” + “”"" + “Down” + “”"" +")"
Resulting in = Name?
When opening the cell and pressing Enter, the formula works without any changes.
afbeelding

Problem 2
It will give me the same error "Range does not exist) when trying to write all four columns.

Column 3 = “=ALS(B” + cstr(Counter) + “=” + “”"" + “Up” + “”"" + “,A” + cstr(Counter)+"," + “”"" + “)”
Column 4 = “=ALS(B” + cstr(Counter) + “=” + “”"" + “Down” + “”"" + “,A” + cstr(Counter) +"," + “”"" + “)”

Problem 2 is solved. Missed the quote (+ “”"") at the end.

“=ALS(B” + cstr(Counter) + “=” + “”"" + “Down” + “”"" + “,A” + cstr(Counter) +"," + “”"" + “”"" + “)”

Problem 1 is now applicable to column 2, 3 and 4.

UiPath_Test.xaml (43.2 KB)

I tested the WF you attached and it works fine for me.
I only changed “ALS” by “IF” due to English excel.
No idea why it doesn’t work for you :frowning:

Cheers

Me neither. I have also checked all kinds of settings without any succes. Creating the formula in UiPath instead of Excel. Thank you for your help @J0ska!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.