Win 11 Context Menu Not Selectable

I have installed Windows 11 on my PC and for some reason, selectors are not available on the context menu when right-clicking on a file. CV cannot find it nor any other technology framework. Does anyone else have the same issue? I need to extract files from an archive and there is no shortcut key to extract all unless I do another way by pressing Win + E then setting the address path in file explorer, then clicking on the Extract button. Right-clicking on the archive and then clicking on Extract All… is much faster. However, I cannot select it. If I click on the Show more options, then the Win 10 context menu is selectable. Any suggestions if this can currently be done?

Try using another Use Application/Browser activity to attach to the context menu


Did you try using a power shell script to extract the files?

that way we can pass the filepath and everything actually happens in background


1 Like

Yes that works pretty well and much faster as you said in the background. Thanks @Anil_G

1 Like

I still got an issue though. When running the script directly from Power Shell using the following command:

Expand-Archive -LiteralPath C:\Users\Administrator\Desktop\ -DestinationPath C:\Users\Administrator\Desktop\archive

The archive extracts well. However, when I invoke powershell in UiPath, I did the following:

Command: “Expand-Archive”
In Paramenters (Collection), I added 4 arguments as type string for all:

Argument 1: “-LiteralPath”
Argument 2: “C:\Users\Administrator\Desktop\”
Argument 3: “-DestinationPath”
Argument 4: “C:\Users\Administrator\Desktop\archive”

When testing the activity, I get the following error:

Invoke Power Shell: The ‘Expand-Archive’ command was found in the module ‘Microsoft.PowerShell.Archive’, but the module could not be loaded. For more information, run ‘Import-Module Microsoft.PowerShell.Archive’.


One thing to correct

your argument1 name will be LiteralPath and value will be the path(" C:\Users\Administrator\Desktop\")
similarly argument2 for DestinationPath ("C:\Users\Administrator\Desktop\archive")

Also if it is a zip file you can use extract activity as well


@Anil_G Same error appears as before

I already tried the extract/unzip files activity before, it does not work in my case. Here’s a thread I made Extracting/unziping files to folder - #11 by neha.upase

Look forget it. I used a start process activity as such:

Executable Path: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe

Arguments: Expand-Archive -LiteralPath C:\Users\Administrator\Desktop\ -DestinationPath C:\Users\Administrator\Desktop\archive

That works as well.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.