Why I got the data result of Excel are different via Studio or Robot to execute?

Hi everyone,

I met a situation that I run the process through Studio smoothly and get the result I expected.

However, After I published the process and execute via UiAgent(Robot), the result is incorrect that it lack some data.

I add the Delay inside the process for 20 second, but when the Robot execute, it always finished in 10 seconds. why this happen?

Here’s my screenshot for your reference
At first, I thought I used the wrong way to assign the data via “For Each Row”, it’s the first pic below:

Then I changed the way as the second pic below:

But it didn’t work.
Both of 2 pictures, I add delay after the multiple assign in case the Robot execute too fast.
But still same.

Does anyone face the same issue?

Thanks in advance

instead of Multiple assign did we try with normal FOR EACH loop

Cheers @opas1216

Hi @Palaniyappan

You mean using normal assign instead of multiple assign in For each loop?

I haven’t tried this way, but I don’t think it will be the reason.

I’ll report the result later.


I tried the normal assign instead of Multiple assign, but still the same incorrect result.
This time still different result came out through Studio(Correct result) and Robot(Incorrect).

Isn’t it the Studio or Robot issue?

Thank you!

1 Like

sometimes robot will run faster when triggered from robot tray or from orchestrator than when ran from studio
hm…fine you said adding delay with 20 seconds didnt work
lets add a delay between each assign with a timespan of around 1 or 2 seconds

Cheers @opas1216

Thanks @Palaniyappan

I’ve not tried your solutions yet, but I got some new info about this issue.

It’s really weird that the robot still cannot get the correct result.
I found that it showed up some log message I wrote which already been commented out in the Execution log during the period I running the Robot …

Could anyone tell me what’s going on??

My colleague contact the UiPath staff got an answer that somehow UiPath also got this issue and didn’t know the reason and had no idea how to solve it. At the end I got an advice to check the version of my packages from Studio and Robot whether identical. :frowning:

1 Like

Is the version in Studio and rebot the same? Maybe you need to publish it and then update it