When using Write range followed by read range getting error message on Specified method is not supported on read range

I am getting a error message specified method is not supported when i use the write range followed by read range on the read range action. The process that i am creating is:
read a text file, generate data table, write range data table into spread sheet, read range from same spread sheet and create new text file and paste in the read range. If split the process in two and i run the write range first and then open the excel spread sheet manually and click save without doing anything else and then run read range it works. Any ideas as to what is causing this error message

I tried replicating the same process and found no error. I use both Excel and Workbook activities without any issue. If you don’t mind, can you share your xaml file?

Thanks Jordan,

I think I have figured it out and that it is the formula in my excel is not compatible when using Workbook. Below is the formula that I am using and attached is the xaml file.

IF(AND(ISNUMBER(SEARCH(‘Static Data’!$A$129,E1,1)),ISNUMBER(SEARCH(‘Static Data’!$B$129,C3,1)),(ISNUMBER(SEARCH(‘Static Data’!$C$129,E3,1)))),“:86:NET TOTAL SWEPT FOR “&‘Static Data’!$D$129& “/ENTRY”,””)

Main.xaml (7.91 KB)

Hey Shane,

Did you try using Read Range within an Excel Application Scope?


Thanks Jordan,

Unfortunately this doesn’t work currently for me as when I use Excel Application scope it is asking me to run a repair tool. I have run the repair tool but it hasn’t made any difference. I have ask my contact at Uipath to look into this for me and am currently waiting to hear back.