When using "Use the version specified in the project file" in UiPath Pack, UiPath Deploy is not updating the process

When using “Use the version specified in the project file” in UiPath Pack, UiPath Deploy is not updating the process to use the latest. It is working fine when using “Auto generate the package version”.

We are using version 2023.4.3 for orchestrator. Can someone please help with this issue?


Hi @rpingili

Where are you using UiPath Pack, UiPath deploy ? Azure DevOps?


Welcome to the community

You are saying in orchestrator after publish the process is not getting updated evebthough latest package is published?


Thanks Anil. That is right. In Azure Pipeline, when using UiPath Pack and choose “use the version specified in the project file”, “UiPath Deploy” is deploying the new version of the package, but it is not updating the process to use the latest version (even though “Automatically create/update process” is selected.


Yes, in Azure Devops.

Hi @rpingili

First, update all UiPath Task to use 4.* version

UiPath Pack


UiPath Deploy Task:


Make sure to provide the folder path in orchestrator, for example

CSC/Account Payable/Invoices

Make sure to use a higher version in project.json file

If the version in project.json already published to orchestrator, you will get a error “Conflict” that you can see in Agent Logs

Thanks @rikulsilva. I followed the steps, still no luck.

Still the process is not being updated:

Could you look in Agent Logs to see if any warnning occurs?

Also, are you using User API or External Application in the connection ?

I am using “New UiPath Orchestrator Connection service connection” to connect to orchestrator. Interestingly, it works fine when using “Auto generate the package version”.

In both scenarios, logs say that the process is updated, but works only in for auto generated package version:

2023-11-27T16:36:01.6046381Z Update processes with names PackageName to latest version.
2023-11-27T16:36:01.6097800Z Update processes with names PackageName to latest version.
2023-11-27T16:36:01.9150239Z Deployed PackageName v2.0.158 to folder Migrated ORPA - Modern.

Could you share the published version and the version into project.json

It doesn’t seem missing permission because you can update using auto generate

Also, the problem occurs for all processes or is specific for this one ?

I haven’t tested another process so far. Will try that.

project.json file contents are listed below. I won’t be able share the published version as I will need to get approvals for that.

“name”: “Mailbox Management”,
“description”: “Blank Process”,
“main”: “Main.xaml”,
“dependencies”: {
“UiPath.Cryptography.Activities”: “1.4.1”,
“UiPath.Database.Activities”: “1.6.1”,
“UiPath.Excel.Activities”: “2.12.3”,
“UiPath.Mail.Activities”: “1.12.3”,
“UiPath.PDF.Activities”: “3.6.0”,
“UiPath.System.Activities”: “22.10.4”,
“UiPath.UIAutomation.Activities”: “22.10.5”,
“UiPath.Word.Activities”: “1.16.2”,
“UiPathTeam.ReadEmailToPdf.Activities”: “[]”
“webServices”: ,
“entitiesStores”: ,
“schemaVersion”: “4.0”,
“studioVersion”: “”,
“projectVersion”: “2.0.159”,
“runtimeOptions”: {
“autoDispose”: false,
“netFrameworkLazyLoading”: false,
“isPausable”: true,
“isAttended”: false,
“requiresUserInteraction”: true,
“supportsPersistence”: false,
“workflowSerialization”: “DataContract”,
“excludedLoggedData”: [
“executionType”: “Workflow”,
“readyForPiP”: false,
“startsInPiP”: false,
“mustRestoreAllDependencies”: false,
“pipType”: “ChildSession”
“designOptions”: {
“projectProfile”: “Developement”,
“outputType”: “Process”,
“libraryOptions”: {
“includeOriginalXaml”: false,
“processOptions”: {
“fileInfoCollection”: ,
“modernBehavior”: false
“arguments”: {
“input”: ,
“expressionLanguage”: “VisualBasic”,
“entryPoints”: [
“filePath”: “Main.xaml”,
“uniqueId”: “aba9cde4-08b6-473e-87bf-5383aa75b84b”,
“input”: ,
“isTemplate”: false,
“templateProjectData”: {},
“publishData”: {},
“targetFramework”: “Windows”

@rikulsilva, I tried running the deployment against different orchestrator version (2022.10.3) and I see below error in the logs:

2023-11-27T20:03:33.4258215Z The package(s) were deployed to Orchestrator, but no process was created. To automatically create/update a process with the latest package please provide a valid environment.

The deployment I was trying earlier was on orchestrator version 2023.4.3. Wanted to see if you have any idea on this error. Appreciate your time and help…!


Hi @rpingili

Environment is only necessary when publishing to a Classific Folder (deprecated). Is this your case?

Which version the process is in Orchestrator?

Hi @rikulsilva, this makes sense. The original error and logs I posted are for “modern” folders in version 2023.4.3. The classic folder was migrated to “modern” folders during the upgrade. Since we had older version on another server with classic folders, I tested against it, and I got the environment missing error there.


Could you share the Agent job log without sensitive information ?

Hi @rikulsilva,

Thanks for your time and help. Sorry for the late reply. We figured out the issue. We found that there were newer versions of packages that are inactive in the orchestrator. This was causing conflicts and UiPath Deploy was not working as expected due to this. Once we cleared up the packages in the orchestrator, the issue is resolved.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.