When completed issue in Start a process rule


I’m trying to start a process when a button is clicked in the UI Path App. The process works fine, but the rules in When Completed part do not work.

I receive an argument from the process named err (string). Sometimes the err comes with N/A (empty string). In that case, I create an entity record to store some details. If there exists any text in err, I will display the err as a message in the app.

Please suggest me ideas on how to check if the err is N/A (empty string) or not to execute some rules based on the value.

Thanks in advance

Make sure the argument that you are passing is an out argument from the Studio Workflow.

The above is how I have set my rule. Here err is an out argument.

I have tried this way too… but still doesn’t work

Just found out that my When Completed block does not work at all, even though I’m not facing any errors… @Dilip_Wakdikar_1996 please respond as soon as possible.


I figured out the solution. Instead of putting the rules in the When Completed section, I moved them after the process and now it works fine.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.