What does if Read range could not read a range?

Im trying to read a range using read range activity but the bot is still keep on executing nor its giving output or error

Hi @cool_babe

Did you add datatable variable in read range activity?
please share screenshot of activity?

Hi @cool_babe

Is the excel file very huge? Or there might be some excels already open kill them uaing task manager before running the bot

Also goto option>trust center>trust center settings> and under it disable all macros and external content and actice x


But I have given only a single sheet to read where as no other excel files are been opened

HI @cool_babe

Can you tell us the size of the excel file. Its huge ah?

Have you Tried with Excel application scope followed by Read Range?



Hi @cool_babe

Just to check give a range like “A1:D4” and check if it is able to read. If not then excel scope can be an alternative but mostly the file is corrupted . You need to recreate it if these fail


File size is 36MB

I have tried with mentioning range of Particular ranhe eg:A1:B250 but still facing the same issue

@cool_babe Can you give “” in range and try ?

Have you tried this? @cool_babe

I have tried initially with “” only, initially my file was in binary extension and file size was 20MB while im running with that extension it shows only xlsx extension will be accepted, so i have changed the file extension to xlsx and the file size too increased as 36MB and facing the issue.

Again try to put “” with xlsx file and see or try excel application scope as @Gokul001 said

Can i see your code?

Hi @cool_babe

If you want to use binary format then use exce scope instead. And i beleive the issue is with the file size…ita really heavy… check task manager while running may be your system is at full utilization.

Try reading excel as datatabse by setting up oledb connections

Here you can get connection strings