Web Activities Package Issue

Hi All,

When I search “UiPath.WebApi.Activities” in Manage Packages then it searches “UiPath.Web.Activities”

When I search “UiPath.Web.Activities” in Manage Packages then it searches nothing.

Also after install this package into the process then it creates issues like it shows “Internal server error” below is the screenshot.


Not able to work in UiPath Studio after installing this package.


It might sound weird, but have you actually tried to restart your UiPath and PC? Just in case


Which version you have installed for this package “UiPath.WebApi.Activities”

@ecarles Many times in restarted UiPath and PC too

@sarathi125 v1.4.4

Kindly check with the previous version of the package, since it is published on 10/18 it may have some issue.

@sarathi125 I already checked with the previous versions one by one. But facing same issue.

Below is the detailed log:


An internal error has occurred. It is recommended to restart UiPath Studio.

Error: System.InvalidOperationException: A TwoWay or OneWayToSource binding cannot work on the read-only property ‘Content’ of type ‘System.Activities.Presentation.Model.ModelItemImpl’.
at MS.Internal.Data.PropertyPathWorker.CheckReadOnly(Object item, Object info)
at MS.Internal.Data.PropertyPathWorker.ReplaceItem(Int32 k, Object newO, Object parent)
at MS.Internal.Data.PropertyPathWorker.UpdateSourceValueState(Int32 k, ICollectionView collectionView, Object newValue, Boolean isASubPropertyChange)
at MS.Internal.Data.ClrBindingWorker.AttachDataItem()
at System.Windows.Data.BindingExpression.Activate(Object item)
at System.Windows.Data.BindingExpression.AttachToContext(AttachAttempt attempt)
at System.Windows.Data.BindingExpression.MS.Internal.Data.IDataBindEngineClient.AttachToContext(Boolean lastChance)
at MS.Internal.Data.DataBindEngine.Task.Run(Boolean lastChance)
at MS.Internal.Data.DataBindEngine.Run(Object arg)
at MS.Internal.Data.DataBindEngine.OnLayoutUpdated(Object sender, EventArgs e)
at System.Windows.ContextLayoutManager.fireLayoutUpdateEvent()
at System.Windows.ContextLayoutManager.UpdateLayout()
at System.Windows.ContextLayoutManager.UpdateLayoutCallback(Object arg)
at System.Windows.Media.MediaContext.InvokeOnRenderCallback.DoWork()
at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
at System.Windows.Media.MediaContext.RenderMessageHandlerCore(Object resizedCompositionTarget)
at System.Windows.Media.MediaContext.RenderMessageHandler(Object resizedCompositionTarget)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler), HResult -2146233079

Hi everyone,

I am facing the same issue and nothing works : reboot, reinstalling packages… I think this is an issue related to this specific package, no?


That’s correct !!


Welcome to the UiPath Community.

How can we resolve this issue ? Because I cannot work, I have a pop up every minute… Have you found a solution?


Are you working on XML activities?



If your process worked on background, then you can use “Background Process Template”.

It works.

Try it and let me know.

Sorry for resurrecting an old thread. But I also have this exact same problem. I get the error dialog so often it’s almost impossible to work.


Is there any answer on this one?
I’m having the same issue.

Are you on Studio 2019.10? If so, updating to the latest patch version 2019.10.5 might fix the issue (I’m not 100% certain).

Versions 20.X have it fixed for sure.

I tried both 2019.10.4 and in order to check if problem still exists, I tried the latest from the community 2020.10.0. Both have the same issue.

Just create a project and add Web activities.
Create a sequence and use web activities in it and also use ‘Read Text File’ in sequence and set the required properties.
Save and close xaml (Some times needs Studio restart also)
Reopen Studio/project/xaml.
If don’t get the error close xaml and open it again.
I get the same error when I click ‘Read Text File’ activity.

Any chance you could share a sample project? It could also help if you could run the uipath diagnostic tool and send us the logs after the crash has happened.