Wait Attribute issue

I’m trying to build the sequence from “Video Demo - Using Property Explorer” from the [RPA Developer Foundation] UiPath Academy course.
I’m not able to make “Wait Attribute” works. It doesn’t detect the changes on any of the attributes of the button “START”/“ROUND 1” on the http://www.rpachallenge.com/
I tried with Chrome and reach timeout without detect change.
Also i tried with Explorer 11 and I got the error: “Wait Attribute: Error HRESULT E_FAIL has been returned from a call to a COM component.
Does somebody can show me an example where Wait Attribute works?
thanks

1 Like

HI @jnl

Is the browser extension working?

Did you do exactly as mentioned in the video?

Hi Fernando.

Yes, i 'have the extension in both browsers, and works well with all activities I tried till now.
I tried exactly as the video shows, and I also followed the Recap instructions, because are not identical.
I attach here …Using Property Explorer.zip (14.6 KB)

Thanks!!

I am having the same exact issue with this demo

Same issue here.
I note that the RPA Challenge website is not he same as the video.
We have tried using Chrome and IE.

What is odd is that if you click the Start button and then run the robot, it detects the attribute. But this doesn’t happen if you run from before you click Start. The Wait Attribute activity will just timeout.

Thanks

Lee.

Same issue here!

Regards,
Marcin

Facing same issue. Almost spent an hour but couldn’t figure out what went wrong. Hoping to see some answers here.

Same issue here also. Tried in Chrome and IE.

Ok. This is what I did to get to make the ROUND 1 button Highlight. As far I understood, the UiElement variable “button” will not be updated after assigning it to the “START” button through Find Element activity. Therefore, the Wait Attribute activity will not be able to identify the ROUND 1 button.
So, I added a new Find Element activity right before the Wait Attribute activity. I indicated ROUND 1 button to the Find Element activity and tried running the process. This time I got an error as shown below,
image
Therefore, I added one more step in the same Find Element activity. In the properties of Find Element activity, I clicked image for Selectors property, in the Selector Editor I clicked image (Wait for sometime to get UI Explorer window) and checked image option. Click save (in the bottom right of the window), it will bring back to the Selector Editor window and click OK. This time, the process worked out successfully.

I am having the same issue. I tried contacting support, but they told me to check the Forums. Is there any resolution to this?