VlookUp_Error

Hi All,

I am getting the error while applying Vlookup as in the attachment please someone help me to resolve the same.

Thanks i


n advance.

1 Like

Hi

In property panel we have missed to mention the column index in TARGET column
Only then it will compare and vlookup
Mention either the column index or column name in the property under TARGET section

Here you go with an example on how to use that activity

Cheers @HeartCatcher

@Palaniyappan
Thanks for your reply I have given the proper target column even after I am getting the same error please help me to get rid of it.
Thanks.

1 Like

Can I see the error in output panel
@HeartCatcher

1 Like

Hi @HeartCatcher

Is the column name “SET ID” present in the datatable.

Thanks

Please find.

@prasath_S

Thanks for your reply

It is set correctly but getting the same error.

Fine

Is the input datatable VlookupData having that column
Pls ensure that once
If it’s there try with column index instead of column name

@HeartCatcher

1 Like

I did that also but getting the same error.

Can I share you the both excel??

@ppr
@Yoichi
Please look into this

HI @HeartCatcher , please check the column name you have provider. error messgae showing something error .

Regards,
Arivu

Pivot_Output.xlsx (42.0 KB)
Spice Money Payments_SEP333’21.xlsx (146.4 KB)
From sheet Pivot_output(I need to consider “Row Labels” column and from sheet Spice Money Payments I want consider “SET ID” column to take the vlookup and the target column is “SET ID” column

1 Like

@HeartCatcher think you have already created the topic for this as I already explained in that topic you have column names from 4th row only that’s why it’s not recognised the column names,

Please try below steps when reading spice money excel,

  1. Use read range activity and read the data (give range as “”) and store it in the datatable variable name dt.

  2. Now again use read range activity and store it in the datatable variable name dt.but now give range as “A4:S” + dt.rows.count.tostring

Thanks

@HeartCatcher you have to use two read range activities,

  1. First one give range as “”
  2. Second one give range as recon_file.rows.count.tostring

Both the outputs should be recon_file

Thanks

But both are different sheet know.
If you dont mind can you explain a bit more please.

@HeartCatcher yes sure.

You are reading the sheet “Sheet1” (have range as “”) in spice money excel file and by default it will read the read the first row as header (have to tick AddHeaders property in read range activity)

But in the actual file the header starts from 4th row.

Hence first we read the data from the sheet1 and store it in the datatable, then change the range starting from A4 (to make 4th row as header).

First read range properties
Sheetnane - Sheet1
Range - “”
Output datatable - recon_file

Second read range properties
Sheetnane - Sheet1
Range - “A4:S” + recon_file.rows.count.tostring
Output datatable - recon_file

We are only changing the range to make 4th row as header as it only contains the SET ID.

Thanks

here you go with a XAML for this
lookup.zip (181.0 KB)

Cheers @HeartCatcher

Thanks verymuch for your help. Its meant a lot.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.