Variant following the Read Range - Headers

Hello

I have a problem reading a file, when I transform my value list into.tostring, the column header appears, while it is not checked in the Read Range action

Do you have any idea where the problem might come from?


image

Thank you. Thank you.
Maud

Hi
welcome to uipath community

–The reason is in READ RANGE ACTIVITY we have disabled the add headers
–so from the first row itself it will take as datarow and gives us a datatable variable as output
usually datatable must have a column header in it
–if we have enabled the ADD HEADERS property then the first row will be the headers
and if disabled then default column headers will be created like Column1

here is an example for you
here in the read range try once with enabling the add headers and disabling the add headers property and look on to the output panel for each run
we could see the difference
sample.zip (7.7 KB)

hope this would help you
Cheers @Maud

Hello,

Thank you for your help.

But for my process, when I have 2 inputs, my “read range” action reads the good values : A1 and A2 value.

But when I have just 1 input, my “read rang” action reads “Column0 or “Column1” and A1 value.

Whether I test with or without “Add Headers” option, when I have 1 value, it’s same result, the column name appears.

Do you know why ?

Thank you

image001.jpg

image002.jpg

project.json (779 Bytes)

ScanOF_SN_Enter.xaml (19.5 KB)

Fine
lets go one by one
–when i have 2 inputs as you say
image

now when i run the read range with ADD HEADERS property disabled we will be getting like this with two default column name created as mentioned already

image

and even if i have only one input it applies the same
image

output would be
image

hope this would help you
so whatever may be whether single input or two input like two rows if the add headers property is disabled default column names will be created for sure, as a datatable must have a column name in it

Cheers @Maud

Hello,

It’s Ok, I add column name in A1 cell, and add “AddHeaders” option.

My “Read Range” activity become in A2 cell.

My result is good for all process.

Thank you for your help.

image001.jpg

image002.jpg

great
if we have enabled ADD HEADERS property then we wont face any issue while being our datarow if starts from second row

Cheers @Maud

1 Like