Validation Error (Reference Required)


When I click on the Validation button provided by UiPath, I receive the following error

however my Bot works perfectly, any suggestions ??

Validation button on exactly where ?

Hi @Rasoul

Double click on the error to see where it navigates to and to see which activity it is taking about in that workflow… Let know what it is… share a screenshot of that activity along with its properties.

He’s talking about the validate button on the top ribbon of Studio bro…

This is the same scenario for excel application scope activity as well.

I’m sharing the scenario about excel application scope as this seems to be a similar scenario though both steps two different activities


Hello Lahiru

Thank you for your reply, so basically I have surrounded my whole process with a Try Catch activity and the extracted the process as a workflow so I can log the the name of the activity that throws an error (apparently this is the way to catch the exact name of the activity that throws an error), so when I double click it just refers me to the whole application and I cant pinpoint the problem exactly to a single activity


Do you have activities related to any XML stuff in that workflow?

If so can you tell me what the activity is?

Also check the assemblies tab. You can find it next to variables, arguments tabs. In there check whether this particular assembly is there. If not you can add one


Actually yes, so it goes like this
File A invokes
File B invokes
File C invokes
File D

and I have checked the “Imports” tab which is beside the variables and arguments, I added System,Xaml as the error refers to is but I still get the same error

Hmm… are there any xml related activities used? Like a deserialized activity or something similar?

1 Like

nop there are not

Hi @Rasoul

I have being reading on this from a dot net perspective since I really couldn’t find anything related for UiPath.

In your project json file, could you check whether there is anything or any line that mentions about these assembly references.

1 Like

Hello, was not able to find anything related here is the Json

Hi @Rasoul I am facing the same issue. Got any solutions? kindly let me know…

Hello, yes from the Import panel i looked for system.xaml.serialization, and I checked it up manually through the dropdown list, because was not able to find through search mode

Thanks rasoul.

Hi everyone, Same issue. I’m double-clicking on the error and it’s bringing me to my Write Cell activity. Any help with this would be amazing.

Hey @BotMonkey is it the same error that @Rasoul was getting? Or is it a different one?

@Lahiru.Fernando Same one unfortunately

2InsertUsers.xaml (25.3 KB)


1 Like

How did you fix it? I am having a similar issue


Have you tried this yet?

From what I can remember, this is what did the trick