Use Application with option close set to never does not open Application

Hi all

As the title states, when I use the activity Use Application/browser and set the option ‘close’ to never.

As this is happening in the RE-Framework in the INIT phase to open and log into an application.

Anybody experiencing the same issue and/or any suggestions or workarounds?
If none I think I’ll switch to open process.

Many thanks

That should open it actually, may be some bug. I see the below thread has some troubleshoot steps for this issue

@Ciprian_Sterea : Can you comment anything new?

Hi Rahul

I’ll try the steps and get back to you, thanks for your reply!

EDIT: So i tried it with another application (notepad) same issue occurred!
so i dove into the logs found some indicating it was the URI so i tried that trick with new URI(path to app) etc to no avail…
Then i found out that: The activity acts normal only the 1st run
so when i close UIPath, Reopen it and open the project and then run all goes ok.

Many thanks

1 Like

@Benjamin_Degryse thanks for reporting. We will try to reproduce it and fix it. What UIAutomation.Activities package version are u using?

@Benjamin_Degryse
Can you please share the project?
Or:

  • a screenshot of the “Use Application” properties
  • a screenshot of project settings UI Automation Moden → Application/Browser section

Please keep in mind that the default setting for OpenMode is IfNotOpened, so, if the previous wf run did not close the application (Close = Never), and the app is still alive, than, on the next wf run, the “Use Application” will attach to the live instance, instead of opening one.
If you want to always open a new instance of the target application, then ensure that OpenMode is set to Always

Hi

Sorry for the delay.

I’m using version: 21.4.4.

Kind regards

Hi

Please find attached the requested screenshots.

What i want to happen is in different WF’s (to separate the logic from the actions etc):

  • Open the app
  • Log into the app
  • Do some actions
  • Close the app when the loop is done.

If anything else is needed let me know.

Kind regards