Update User Password via HTTP (PUT) -> Error 500

Hello community,
I am currently running a script that shall change a user password in Orchestrator via a PUT - http request. This worked approximately 1 month ago, but I run into an error 500 now and I dont know why.

Does somebody know why this happened out of a sudden or how to troubleshoot this? Or where to look to check settings etc?

Thanks in advance.

Best regards

1 Like

Hey @BennyS

We need to see the request details on what you are passing…

I hope you have necessary access as well to update the user !


Hello @Nithinkrishna

I am using the following Endpoint:
“odata/Users(” + RobotID + “)”

For the payload, I am first getting the JSON content via a Get (This is working), then replace the old password within the json content with the new one and then uploading it again via the Put command - This Put is not working.

1 Like

Hey @BennyS

Please show the PUT as well and make sure you have sufficient access to edit those !


   ""@odata.context"": ""..."",
   ""Name"": ""Test1"",
   ""Surname"": ""Test2"",
   ""UserName"": ""Test1234"",
   ""Domain"": null,
   ""FullName"": ""Test1 Test2"",
   ""EmailAddress"": """",
   ""IsEmailConfirmed"": false,
   ""LastLoginTime"": null,
   ""IsActive"": true,
   ""CreationTime"": ""2022-03-03T14:12:35.003Z"",
   ""AuthenticationSource"": null,
   ""Password"": null,
   ""IsExternalLicensed"": false,
   ""RolesList"": [
   ""LoginProviders"": [
   ""TenantId"": 1,
   ""TenancyName"": ""Default"",
   ""TenantDisplayName"": ""Default"",
   ""TenantKey"": ""..."",
   ""Type"": ""User"",
   ""ProvisionType"": ""Manual"",
   ""LicenseType"": null,
   ""Key"": ""..."",
   ""MayHaveUserSession"": true,
   ""MayHaveRobotSession"": false,
   ""MayHaveUnattendedSession"": true,
   ""BypassBasicAuthRestriction"": false,
   ""MayHavePersonalWorkspace"": false,
   ""RestrictToPersonalWorkspace"": false,
   ""Id"": 14,
   ""RobotProvision"": null,
   ""UnattendedRobot"": {
     ""UserName"": ""...\\Test"",
     ""Password"": ""Test123567"",
     ""CredentialStoreId"": 1,
     ""CredentialType"": ""Default"",
     ""CredentialExternalName"": null,
     ""LimitConcurrentExecution"": false,
     ""RobotId"": 8,
     ""ExecutionSettings"": {
       ""LoginToConsole"": false
   ""NotificationSubscription"": {
     ""Queues"": true,
     ""Robots"": true,
     ""Jobs"": true,
     ""Schedules"": true,
     ""Tasks"": true,
     ""QueueItems"": true,
     ""Insights"": true

This is the JsonObject which I am trying to PUT. The only thing that I have changed is the (UnattendendedRobot)(Password)
This is working on acceptance, but not on Production anymore. It has been working 1 month ago, the only thing that has changed is the update of the SSL certificate. Might this be a problem?

The robot is updating its own login credentials - this might also be a problem, but it worked 1 month ago.

The access rights are set to be able to view and edit users.

Maybe: A good debugging question would be : How can I use the basic HTTP Request wizard for the production orchestrator? I can’t get the http request wizard to work - all tries lead to “not authenticated”. Which endpoint do I have to use? Which auth. method?

1 Like

for a 500 Error we would recommend to check manually if Orchestrator is up and running. Then check with swagger if the reast api is up and running

Hey @BennyS

Is the request correct as per docs ?


Thank you @ppr for your response
Somehow, Orchestrator is online, and swagger is working.

@Nithinkrishna as the Put request works on the acceptance environment, I guess that it is correct.

1 Like

Okay great @BennyS

I was just suspecting the odata context prop.


Does somebody have any idea how to find out what this Error 500 is exactly about?

@ppr do you have any idea where I can further take a look for troubleshooting?