Unable to Type Into an Admin Command Prompt

There is a case where i am trying to Type into ipconfig /flushdns command on an Admin Command Prompt. Able to open an Admin Command prompt after creating scheduled task in Windows. Win +R and Type Into ‘“schtasks /run /tn \MyApps\cmdprompt[k(enter)]”’
opens up a Administrative command prompt.
On further Type into command says selector not found though a valid Selector has been set “”

Request any inputs about how to get the Type Into command to work on the Administrator Command Prompt.

Selectors for Admin command prompt.

Hy @mailsmithash,

I have worked on command window, it can be done.
Could you share me your workflow so I can take a look?

Thank you!


@mailsmithash, Replace your selector with:

<wnd app='cmd.exe' cls='ConsoleWindowClass' title='C:\WINDOWS\system32\cmd.exe' />

And after you typed in one command use another type into to type cls + enter to clear command window before trying another command.

AdminCommandWindow.xaml (15.8 KB)

Please find the workflow, i am able to launch an Administrator Command Prompt, but later Type Into doesn’t work due to selector issue.

The above doesn’t seem to be working, it still throws up Selector issue.

Hy @mailsmithash,

Please check my workflow, I havent used selector to type in the Command Prompt, please have a look. Any questions please let me know.

AdminCommandWindow_Test.zip (24.1 KB)


Thanks, if launches the Run Window and doesn’t proceed further…getting the below error

Changed the selectors and the workflow that you sent seems to be working, but it still opens up a regular Command prompt and not an Administrator command prompt as required.

Hy @mailsmithash,

I have adjusted the workflow, please have a look:

AdminCommandWindow_Test.zip (24.5 KB)

Those are the instructions i used to open the command prompt as admin


The workflow does bring up the UAC(which requires user intervention), which has been disabled in the first workflow that i attached by running it from the Windows Scheduler by using the below command "‘“schtasks /run /tn \MyApps\cmdprompt[k(enter)]”’

where i had created a cmdprompt task in the Task Scheduler and given elevated priviliges, so was able to launch the Admin Command Prompt, but the further Type Into doesn’t work.

The UAC can be bypassed following the above.(in the first workflow attached)
It does however launched Admin prompt but Type into doesn’t work from Uipath.

@mailsmithash, you might be required to also run UiPath studio as Admin

This selector worked for me in the Type Into Activity:
<wnd app='cmd.exe' cls='ConsoleWindowClass' title='Administrator: Command Prompt' />

AdminCommandWindow.xaml (18.7 KB)
And if this still doesn’t work, you need to use computer vision. use the CV Type Into Activity.

1 Like

Running Uipath in Administrative mode, results in Access denied. If I disable Administrator mode of Uipath,able to reach till the Admin prompt opening up. Let me try the CV Type into , but that requires Orchestrator API

Even CV Type Into doesn’t seem to be working getting the below error:

A Poweshell script was written to run the commands in background as a workaround. Solving the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.