Unable to run this program with netpipe issue. help!

Hi, I am having problem with uipath community edition.

I downloaded uiPath Community edition with my window 10 computer and i get this message

when i click the run button.


19.5.0+Branch.master.Sha.a03bc4726ca82b7bb3addb0d04106dc150b31fba

There was no endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/user that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/user that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

Server stack trace:
at System.ServiceModel.Channels.ConnectionUpgradeHelper.DecodeFramingFault(ClientFramingDecoder decoder, IConnection connection, Uri via, String contentType, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.CallOpenOnce.System.ServiceModel.Channels.ServiceChannel.ICallOnce.Call(ServiceChannel channel, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)
at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at UiPath.Models.IUiPathRemoteDuplexContract.GetRobotConnectionStatus()
at UiPath.Models.UiPathDuplexProxy.GetRobotConnectionStatus()
at UiPath.Studio.Plugin.Workflow.Services.RobotStudioBridge.Execute(WorkflowDocument document, Boolean isDebugging)


I searched the forum for solution, and i tried

this solution that this didnt work with me.

[Okay I did a complete re- installation after deleting the folders from Roaming and Local in %appdata%. Before that I went to Windows features and enabled all the features under .Net after which I could see the net.pipe listener service running which was previously missing. This appears to have resolved the issue. I would like to sincerely thank everyone for their assistance and support. This really is a fantastic community :slight_smile:]

I can see net.pipe Listener Adapter working in window service.

Please help me to start this progam.

Thank you.

Hi @Dohyeong_Lee,
Welcome to the Community!
You can try also to install newest version of .Net

1 Like

i get net.pipe error when i press run button when i use my account with administrator right.

i did every solution that worked with other people but didn’t work with me.

i spend hours to reinstall but i saw a article about hidden built in administrator account.

i went cmd with admin right-> type below
net user Administrator /active :yes

-> and done with cmd

-> windowkey+R netplwiz

-> uncheck that “User must type~~~”

->restart computer or logout and login with Admin account named ‘Administrator’

with this admin right, uipath works without problem but all my icons and setting were gone.
since it is different account

so i had to [ net user Administrator /active :no ] and go back to my account to get my settings back.

For my opinion, this problem occured from that uipath community v5.0 is now a Window app,

my account doesnt have right to access(including writing) C:\Program Files\WindowsApps

but hidden admin account can access.

i hope to find a different way to solve this problem.

if you know any kind of information about this problem, plz help me.

Thank you.

Well, UiPath didn’t changed anything it that matter. I look like your specific user account configuration is blocking this. Please remember that some part of the workflow is in fact working like a code, and for some specific domain accounts/ restricted accounts there are policies set by administrators which prevents from running code. It security reason.

If it’s your own private computer then you shouldn’t have any problem like this as default Windows account has administrative privileges.